DDBOOST_USER' does not have sufficient access rights is seen from the NetWorker side

Summary: "DDBOOST_USER' does not have sufficient access rights" is seen from NetWorker side even though DDBOOST user is working fine from DD side. Also if you tried to change PW, assign a new SU it shows the same error "DDBOOST_USER' does not have sufficient access rights" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Customer can log in with the same ddboost user that is getting the error for with no issue from the DD side.

From DD SUB logs you see something similar to the below:

[ddfs.info]:

09/02 14:59:42.999817 [b7e3c10] WARNING: Client DDBOOST_USER did not match access list entries
09/02 14:59:42.999839 [b7e3c10] nfsproc3_ost_mnt_3_svc: client access denied for IP x.x.x.x version x.x

 

Cause

DDBOOST_USER' does not have sufficient access rights is seen from the NetWorker side.

DD integrated with NetWorker might see an error as follows:
Unable to connect error

DDBOOST_USER' does not have sufficient access rights is seen from NetWorker side even though DDBOOST user is working fine from DD side and also if you tried to change password, add new ddboost user, assign new SU it shows same error "DDBOOST_USER' does not have sufficient access rights."

 

Resolution

When Encryption and Authentication settings had been configured for DD Boost. You then have to add in the clients that can access the DD over DD Boost protocol. It might have not been done by the implementation engineer.

The issue is ddboost client access issue.

Fix:
Adding the Windows client to the access list resolves it.

# ddboost clients add <client>

 

Affected Products

Data Domain, NetWorker
Article Properties
Article Number: 000275554
Article Type: Solution
Last Modified: 23 Apr 2025
Version:  2
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