PowerFlex Upgrade failed with error related to https port 443

Summary: This article explains how to troubleshoot PowerFlex Upgrade failure due to the absence of a firewall policy for https port 443

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex upgrade failed with an error related to port 443  

 

"Encountered an error during firmware update"

"msg": "Request failed: <urlopen error timed out>",
"url": "https://10.10.10.10:443/httpshare/download/8aaa8139968243590196832f22000ab4/modified/VMware-ESXi-8.0U3-24022510-depot.zip"

Cause

ESXi MGMT host does not have an outgoing firewall policy for https port 443

Resolution

On an ESXi host, go to the Networking tab, and you will find the firewall rules sub-tab, Under that, you can enable and allow the required ports and IP addresses, respectively. 

Enable port 443 (HTTPS) on the ESXi host, which allows the host to connect to the HTTPS share and download the depot file 

Affected Products

ScaleIO
Article Properties
Article Number: 000323657
Article Type: Solution
Last Modified: 23 May 2025
Version:  1
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