PowerProtect Data Manager: PPDM UI에서 검색 클러스터의 상태는 특정 검색 노드가 실패 상태임을 표시합니다

Summary: 검색 노드가 응답하지 않게 되고 인덱싱 작업은 실패한 노드에서 실행할 수 없으므로 대기 상태로 유지됩니다. 이 문제는 19.16 릴리스 또는 이전 버전의 검색 노드에서 발생할 수 있습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

실패 상태의 검색 노드에서 /var/log로 이동하여 메시지 로그를 확인합니다. 다음과 유사한 항목이 표시됩니다.

2024-07-08T10:00:12.049322-04:00 search_node_name kernel: [518834.025665][    C1] watchdog: BUG: soft lockup - CPU#1 stuck for 235970s! [nfsd:2692]

영향을 받는 버전: 19.16 이하

PPDMESC-6808에서 Dell 엔지니어링이 조사함

 

Cause

검색 클러스터의 NFS 데몬이 OS 수준 "소프트 잠금"에 도달합니다. 소프트 잠금에 대한 자세한 내용은 다음을 참조하십시오 https://www.suse.com/support/kb/doc/?id=000018705
이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.

 

Resolution

해결 방법:
nfsd가 응답하지 않는 검색 노드에 로그인합니다.

참고: 검색 노드에 대한 자격 증명이 필요한 경우 루트 사용자로 PPDM 어플라이언스에서 다음 명령을 실행합니다.
source /opt/emc/vmdirect/unit/vmdirect.env  &&  /opt/emc/vmdirect/bin/infranodemgmt get -secret 

이렇게 하면 검색 노드에 대한 관리자 및 루트 자격 증명이 제공됩니다. admin 사용자로 해당 검색 노드에 대한 SSH 세션을 열고 다음 명령을 실행합니다.

echo 20 > /proc/sys/kernel/watchdog_thresh

이 명령은 Watchdog 임계값을 20으로 수정합니다. 그러나 이 구성 변경 사항을 적용하면 서버를 다시 시작할 때 지속되지 않습니다. 서버를 다시 시작할 때 이 상태가 유지되도록 다음과 같이 변경합니다.

echo "kernel.watchdog_thresh=20" > /etc/sysctl.d/99-watchdog_thresh.conf
sysctl -p  /etc/sysctl.d/99-watchdog_thresh.conf

영구 수정: PowerProtect Data Manager 버전 19.16 P2 및 19.17+ 릴리스

 

Products

PowerProtect Data Manager
Article Properties
Article Number: 000228169
Article Type: Solution
Last Modified: 07 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.