Connectrix Brocade: "프로세서 재부팅 완료 - 소프트웨어 장애:ASSERT"

Resumen: 이 문서에서는 "Processor rebooted - Software Fault:ASSERT" 오류로 인해 스위치가 재부팅된 경우의 해결 방법에 대해 설명합니다.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

다음 오류로 인해 스위치가 재부팅되었습니다.

Processor rebooted - Software Fault:ASSERT

 

Causa

"Software Fault:ASSERT"는 소프트웨어 문제이며 CP1(이전 활성)에서 발생했으며 다른 CP 0(이전 대기)으로 페일오버되었습니다.
라우팅 서비스에 문제가 있었고 데이터를 가져오는 동안 null 포인터가 수신되었습니다.

 

페일오버 후:

Fabric OS: v7.1.1c1

hadump        :
---------------------------------------
TIME_STAMP: Mar  7 11:23:37.498073
---------------------------------------
Local CP (Slot 6, CP0): Active, Cold Recovered
Remote CP (Slot 7, CP1): Standby, Healthy
HA enabled, Heartbeat Up, HA State synchronized

errdump:
2019/03/04-00:22:05, [HAM-1004], 30432, SLOT 7 | CHASSIS, INFO, ED_DCX8510_8B, Processor rebooted - Software Fault:ASSERT.


Core.pd file:

MSR: 00029200 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 0/0
TASK = b06c8e10[1869] 'RTEK_TH' Last syscall: -1
ASSERT - Failed expression: op != NULL,
         file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183, kernel mode
         args = 0


set_reboot_reason reason=Software Fault:ASSERT
Kernel panic - not syncing: fabos assertion failed cpu 0:
ASSERT - Failed expression: op != NULL,
         file = /vobs/projects/springboard/build/swbd62/fabos/src/sys/lib/fabos/fabobj_mgr/fabmedia.c, line = 183
         args = 0

PD Start
PowerPC Book-E Watchdog Shutdown soft timer
PLATFORM_FIRST
MTRACER
mtracer_panicdump
mtracer_panicdump write=0x44a1
reboot_reason
PD_MISC
CONSOLE_LOG
6300 KBytes in 2 file(s)
use "supportsave" command to upload

 

Resolución

라우팅 서비스의 소프트웨어 결함으로 인해 Brocade 결함 DEFECT000440968에 장애가 발생했습니다.
이 문제를 해결하려면 스위치를 FOS 7.4.x 이상으로 업그레이드해야 합니다.

 

Productos afectados

Connectrix
Propiedades del artículo
Número del artículo: 000055899
Tipo de artículo: Solution
Última modificación: 30 ago 2024
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.