NetWorker Module for Microsoft SQL VDI Restore kan mislykkes med feilen "nsrsqlrc: Feil under åpning av båndøkt for MSSQL$Inst_Name:/DB_Name»

Resumen: Gjenoppretting av NetWorker Module for Microsoft (NMM) SQL Virtual Device Interface (VDI) kan mislykkes med feilen "nsrsqlrc: Feil under åpning av båndøkt for MSSQL$Inst_Name:/DB_Name." ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Produktet:
NetWorker Module for Microsoft (NMM) versjon 19.4.0.1

Problem:
NMM SQL Virtual Device Interface (VDI) gjenoppretting kan mislykkes med feil:
nsrsqlrc: Error opening tape session for MSSQL$Inst_Name:/DB_Name
Følgende feil finnes i feilsøkingslogger 9:
nsrsqlrc: 10/25/23 16:41:09.172978 lgto_auth: redirected to Server_Name.FQDN.com prog 390103 vers 2
nsrsqlrc: 10/25/23 16:41:09.219849 lgto_auth for `nsrmmd' succeeded
nsrsqlrc: 10/25/23 16:41:09.266733 RPC Authentication: Client failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential
nsrsqlrc: 10/25/23 16:41:09.266733 Could not get a session key for GSS authentication.  Perhaps this authentication method is not allowed/supported by both the local and remote remote machines.
nsrsqlrc: 10/25/23 16:41:09.266733 Falling back to use the older protocol which does not support pipe impersonation. Perhaps were are talking to an older auth server.
nsrsqlrc: 10/25/23 16:41:09.297987 RPC Authentication: Client failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential
nsrsqlrc: 10/25/23 16:41:09.297987 Could not get a session key for GSS authentication.  Perhaps this authentication method is not allowed/supported by both the local and remote remote machines.
nsrsqlrc: 10/25/23 16:41:09.297987 Failed to create lgto_auth credential for RPCSEC_GSS: Could not get session key from FQDN_name.com for GSS authentication with FQDN_name.com: Authentication error; why = Server rejected credential
nsrsqlrc: 10/25/23 16:41:09.297987 direct recover mmd auth failed: Could not get session key from FQDN_name.com for GSS authentication with FQDN_name.com: Authentication error; why = Server rejected credential
(pid=12312,25-10-2023 16:41:09) [7768]D:/views/nw/19.4/nsr/db_apps/bsmsql/sqlio.c(1268):Error failed to obtained tape session for null
(pid=12312,25-10-2023 16:41:09) [7768]D:/views/nw/19.4/nsr/db_apps/bsmsql/sqlio.c(1269): Exiting openWorkItem(), BSAGetObject() failed.
(pid=12312,25-10-2023 16:41:09) [7768]D:/views/nw/19.4/nsr/db_apps/bsmsql/sqlio.c(1420): Entering getWorkItemName().
(pid=12312,25-10-2023 16:41:09) [7768]D:/views/nw/19.4/nsr/db_apps/bsmsql/sqlio.c(1445): Exiting getWorkItemName().
37840 25-10-2023 16:41:09  Error opening tape session for MSSQL$Inst_Name:/DB_Name.

xbsa.messages file
XBSA-1.0.1 19.4.0.1.Build.95 12312 Wed Oct 25 16:40:07 2023           _nwbsa_is_retryable_error: received a retryable network error (Severity 2 Number 7): Could not get session key from FQDN_name.com for GSS authentication with FQDN_name.com: Authentication error; why = Server rejected credential
XBSA-1.0.1 19.4.0.1.Build.95 12312 Wed Oct 25 16:41:09 2023           _nwbsa_is_retryable_error: received a network error (Severity 2 Number 7): Could not get session key from FQDN_name.com for GSS authentication with FQDN_name.com: Authentication error; why = Server rejected credential

Causa

nsrla-databasen på klienten er bare konfigurert for nsrauth: 0.0.0.0/0, nsrauth

Resolución

  1. På SQL-klienten oppdaterer du nsrla-databasen med nsrauth/oldauth ved hjelp av følgende trinn:
nsradmin -p nsrexec
. nsrla
show auth methods
p
update auth methods: "0.0.0.0/0,nsrauth/oldauth"
y
p
q
  1. Start alle NetWorker NMM-tjenester på nytt på klienten.
  2. Kjør NMM SQL VDI-gjenoppretting på nytt.
Propiedades del artículo
Número del artículo: 000219087
Tipo de artículo: Solution
Última modificación: 01 nov 2023
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.