Avamar: Slow backup due to third-party software modifying metadata for unchanged files

Resumen: Avamar backup runs slow due to third-party software modifying metadata for unchanged files.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Avamar backups take a long time to complete and may time out.
 
Avamar backups take a long time and are found to be processing unusually large proportion of modified files.

For example:
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new)
avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour) 

Causa

The Avamar client process, avtar, relies on the ctime of a file to determine if that file changed.
If third-party software alters the ctime of a file in the dataset, avtar considers the file as changed.
Avtar processes the entire file (chunk, compress, and hash).  

This can take considerable time if many files have had their ctime modified.

Resolución

Compare the latest backup log with earlier backup logs to understand if the behavior is normal.

I
f the behavior differs greatly, consider that some other process, or program may be causing the data to change.

Investigate which whether any third-party applications are updating file metadata either be due to malfunction or design.  

Ensure that the latest patches are applied for the third-party product. 
Discuss with the vendor's support team whether it is possible to prevent the behavior from occurring.

Avamar Support has observed this behavior with the following third-party products.

Sophos:
Trend Micro:

Symantec:

  • Links to the Symantec document have since become unavailable
Netbackup:

Información adicional

Practical troubleshooting:
The Process Monitor tool may be useful to help identify which process is causing large numbers of files to be modified or created.



Productos afectados

Avamar

Productos

Avamar, Avamar Client
Propiedades del artículo
Número del artículo: 000041049
Tipo de artículo: Solution
Última modificación: 06 feb 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.