Connectrix: Los datos históricos y en tiempo real de SANnav no se muestran en SANnav

Resumen: No se pueden ver los datos de rendimiento reales e históricos de los switches en SANnav.

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Síntomas

El usuario no puede ver los datos de rendimiento reales e históricos en SANnav. 

Se validó que el puerto SNMP se agregara a firewall-cmd --list-all.

Causa

Actualización del FOS del switch y cambios en la red o la configuración. 

Resolución

  1. Determine si el problema está relacionado con SNMP o telemetría según el modelo de switch y FOS. 
Modelo de switch y FOS Cómo se recolectan los datos
  1. Ejecute el comando troubleshooting-sannav.sh script que se encuentra en <SANnav_Home>/bin/directory.
[root@xxxxxxxxxx bin]# sh troubleshooting-sannav.sh [troubleshooting-sannav.sh]

Select an option to execute and press enter:

  1) SANnav service status checks

  2) SANnav system requirement checks

  3) SNMP and Syslog checks

4) Telemetry checks

ESC) Press Esc and Enter to exit
  1. Seleccione la opción 3 o 4 según el protocolo utilizado.
En el siguiente ejemplo, se muestra el problema de telemetría del switch 10.10.xx.xx. 
troubleshooting-sannav.sh

Comprobación del registro y el estado de la configuración de telemetría del switch, los perfiles y el certificado raíz de CA asociado. 
Además, el estado del puerto para los servicios relacionados con la telemetría en el servidor tarda un poco.

Ingrese una lista separada por comas de direcciones IP del switch: 10.10.xx.xx
Prueba: Validar los perfiles de telemetría
Profile: Profile_PortMetrics_10_xxx.x.xx Error status: Schema on server and switch is incompatible. Check Server and Switch Schema.
        Profile: Profile_FCIPTunnelMetrics__10_xxx.x.xx Error status: Schema on server and switch is incompatible. Check Server and Switch Schema.
        Profile: Profile_FCIPCircuitMetrics__10_xxx.x.xx Error status: Schema on server and switch is incompatible. Check Server and Switch Schema.
        Profile: Profile_GigEPortStats__10_xxx.x.xx Error status: Schema on server and switch is incompatible. Check Server and Switch Schema.
        Profile: Profile_ChassisMetrics__10_xxx.x.xx Error status: Schema on server and switch is incompatible. Check Server and Switch Schema.
                      
Para problemas relacionados con SNMP: 
  •  Valide que los puertos 161 y 162 necesarios para SNMP funcionen entre el switch y SANnav. 
  • Valide que la configuración de SNMP sea precisa, agregue la dirección IP de SANnav a la lista de control de acceso si hay varias IP configuradas. 
Para problemas relacionados con telemetría:
  •  Valide que el puerto de telemetría esté abierto entre SANnav y el switch. Puerto 18081, 18082, 19094 [para switches IPV4] o 19095 [para switches IPV6]
  •  Compruebe si el certificado de Kafka es válido en el switch brocade mediante el comando seccertmgmt command
  1. Una vez realizado lo anterior, quite y monitoree el switch en SANnav para resolver el problema.

Para obtener más detalles sobre la solución de problemas, consulte la Guía del usuario del portal de administración de Brocade SANnav 2.3.1x, sección "Solución de problemas de fallas de telemetría y SNMP"Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

Información adicional

Productos afectados

Connectrix SANnav
Propiedades del artículo
Número del artículo: 000224084
Tipo de artículo: Solution
Última modificación: 14 ago 2025
Versión:  3
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