NetWorker NMC 19.13: No se puede iniciar la interfaz de usuario de NMC, "no se encontró una JVM adecuada"

Resumen: No se puede iniciar NetWorker Management Console (NMC) en NetWorker 19.13 y versiones posteriores.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

NetWorker Management Console (NMC) 19.13 (o posterior):

Unable to launch NMC user interface.

Iniciar el archivo descargado gconsole.jnlp dio lugar a una Read error.

No se pudo analizar JNLP

Inicio de NMC desde la línea de comandos con el comando javaws https://NMC-server:9000/gconsole.jnlp Falla con No suitable JVM was found to start the application.

No hay JVM adecuada

Causa

La falla se debe a un conflicto de resolución de nombres que involucra a dos servidores NetWorker Server que comparten el mismo nombre de host, pero están asignados a diferentes direcciones IP. Esto causaba ambigüedad durante la resolución del nombre de host y afecta el inicio de NMC.

Resolución

Se eliminó el IPADDR_REPLACE_AT_RUNTIME string de la cadena de la gconsole.jnlp para eliminar la sustitución dinámica de IP y garantizar una resolución coherente del nombre de host.

  • Linux: /opt/lgtonmc/web/gconsole.jnlp
  • Windows (valor predeterminado): C:\Program Files\EMC NetWorker\Management\GST\web\gconsole.jnlp

Líneas afectadas modificadas (la dirección IP que se muestra es un ejemplo):

DE:

codebase="https://IPADDR_REPLACE_AT_RUNTIME(192.168.9.150):9000/" 
<argument>IPADDR_REPLACE_AT_RUNTIME(192.168.9.150)</argument>

PARA:

codebase="https://192.168.9.150:9000/" 
<argument>192.168.9.150</argument>

Estas líneas se actualizaron para utilizar una dirección IP estática a fin de evitar conflictos con el servidor NetWorker Server de nombre similar.

Asegúrese de que el host del cliente de NMC (host que inicia NMC) pueda resolver correctamente la dirección de los servidores de NMC. Si el cliente de NMC no resuelve el host correctamente, el iniciador de NMC puede informar "Unable to connect to server hostname, make sure the server is running”.

  1. Valide que el host del cliente de NMC pueda resolver el nombre de host (símbolo del sistema de PowerShell): tnc hostname -p 9000
  2. Si el comando anterior no se conecta, pero se puede acceder al servidor desde la IP, cree una entrada de archivo de hosts para el servidor.

Información adicional

Productos afectados

NetWorker

Productos

NetWorker Family
Propiedades del artículo
Número del artículo: 000361215
Tipo de artículo: Solution
Última modificación: 03 dic 2025
Versión:  2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.