PowerPath: Después de instalar PowerPath en Windows 2016, los dispositivos Clariion y Symmetrix ya no son visibles

Resumen: Después de la instalación de Windows 2016, todos los discos SAN conectados son visibles, pero tan pronto como se instala PowerPath 6.1, los discos SAN desaparecen en Administración de discos y PowerPath no puede mostrar los discos. Esto solo sucede después de la primera instalación de PowerPath. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Instalación de PowerPath en un entorno W2K16 recién instalado.

Después de instalar PowerPath en Windows 2016, los dispositivos de almacenamiento Dell EMC ya no son visibles.

SOFTWARE DELL-EMC: PowerPath 6.1 para SO Windows
: Windows Server 2016 (W2K16)
Almacenamiento DELL-EMC: Clariion/VNX/Unity
Almacenamiento de Dell-EMC: Los errores "mpio 47" de la familia

Symmetrix/VMAX aparecen en un reinicio justo después de la instalación de PowerPath en Windows 2016.

20/10/2017 04:29:08 Nombre del servidor de error 47 mpio Se produjo un error mientras el sistema intentaba reclamar una ruta de I/O de múltiples rutas (MPIO). La ubicación de la ruta fallida se describe mediante la dirección SCSI (1, 0, 0, 0) (puerto, bus, destino, LUN). Para resolver este problema, reinicie el sistema o muestre los dispositivos ocultos en el Administrador de dispositivos e intente desinstalar el dispositivo de disco específico indicado anteriormente y, a continuación, vuelva a analizar en busca de cambios de hardware. 20/10/2017 04:28:55 a. m. Nombre del servidor de información 2 EmcpBase PowerPath Framework controlador cargado. 20/10/2017 04:28:55 Nombre del servidor de información 2 EmcpMpx Controlador de PowerPath EmcpMpx cargado. 20/10/2017 04:29:16 Nombre del servidor de información 6009 Registro de eventos Microsoft (R) Windows (R) 10.00. 14393 Multiprocesador libre.


No se crean dispositivos MPIO adecuados y tampoco se instala el módulo específico del dispositivo de Microsoft (DSM) para Symmetrix.<RAÍZ\wmi>

MPIO_PATH_INFORMATION InstanceName* = "ROOT\MPIO\0000_0" NumberPaths = 0x0 PathList = <null>

 
Si se elimina PowerPath (es decir, sin funcionalidades de múltiples rutas), no aparecen errores "mpio 47" y los dispositivos son visibles.

24/10/2017 06:16:58 Advertir Nombre de servidor 158 Disco El disco 15 tiene los mismos identificadores de disco que uno o más discos conectados al sistema. Vaya al sitio web de soporte técnico de Microsoft (http://support.microsoft.comEste hipervínculo lo redirige a un sitio web fuera de Dell Technologies.) y busque KB2983588 resolver el problema. 24/10/2017 06:17:05 a. m. Nombre del servidor de información 6009 Registro de eventos Microsoft (R) Windows (R) 10.00. 14393 Multiprocesador libre.

Causa

La instalación de MPIO es obligatoria para que PowerPath funcione. En Windows 2016, al igual que con otros sistemas operativos Windows (W2K12 y W2K8 R2 SP1), PowerPath intenta instalar MPIO primero si aún no está presente.

En W2K16, la instalación de MPIO arroja un resultado correcto con la necesidad de reiniciar. Dado que un eventual reinicio es obligatorio para la instalación de PowerPath, PowerPath supone que la instalación de MPIO se realizó correctamente. Sin embargo, en W2K16, los controladores de MPIO aún no están configurados cuando se devuelve el estado correcto. MPIO sobrescribe la instalación del controlador DSM de PowerPath cuando realmente configura sus controladores.

Por lo tanto, los DSM de PowerPath para la familia de arreglos Clariion y Symmetrix no tienen ningún nodo de dispositivo en los sistemas afectados, por lo que no podrían administrar los dispositivos.

Resolución

La corrección se incluye en PowerPath para Windows 6.3.

La solución alternativa cuando se utiliza la versión anterior de PowerPath es la siguiente:Para evitar este problema, utilice el siguiente procedimiento cuando instale PowerPath para Windows en un servidor W2K16:

  1. Instalar MPIO manualmente mediante el Administrador del servidor

  2. Reinicie el servidor. 

  3. Instalar PowerPath para Windows 6.X

  4. Reinicie el servidor. 

Para resolver un servidor que experimentó este problema:

  1. Desinstalar PowerPath y reiniciar el servidor

  2. Asegúrese de que MPIO esté instalado correctamente; si no es así, desinstale y vuelva a instalar.

  3. Instale PowerPath y reinicie el servidor. 

MPIO no sobrescribirá esta segunda instalación de PowerPath, ya que MPIO ya está instalado cuando se inicia nuevamente la instalación de PowerPath.

Productos afectados

PowerPath
Propiedades del artículo
Número del artículo: 000061944
Tipo de artículo: Solution
Última modificación: 11 sept 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.