NetWorker vProxy back-up mislukt met "Unable to create non-quiesced snapshot after a retry attempt: Een ongeldige snapshotconfiguratie gedetecteerd"

Resumen: De integratie van NetWorker VMware Protection (NVP) is geconfigureerd met de vProxy Appliance. De back-up van de virtuele machine (VM) voor sommige VM's mislukt met een foutmelding over de ongeldige snapshotconfiguratie. De snapshotweergave van de vSphere Web Client voor de VM geeft geen beschikbare snapshots voor de VM weer. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Het back-upsessielogboek toont:
...
YYYY-MM-DD HH:MM:SS INFO:   [167] Creating snapshot of virtual machine ...
YYYY-MM-DD HH:MM:SS ERROR:  [167] Unable to create non-quiesced snapshot after a retry attempt: Detected an invalid snapshot configuration.
YYYY-MM-DD HH:MM:SS ERROR:  [167] Unable to create snapshot.
YYYY-MM-DD HH:MM:SS INFO:   [167] Enabling storage migration of virtual machine ...
YYYY-MM-DD HH:MM:SS INFO:   [167] Storage migration successfully enabled: "vm-4030" @ "my_vm_name.my_domain.com" 
YYYY-MM-DD HH:MM:SS WARN:   [167] Virtual machine left locked by backup session because cleanup is required.  Snapshot was not removed.
...

Het VMNAME_vmware-###.log toont:
...
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk: Failed to branch disk: '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' -> '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000004.vmdk' : The file already exists (39)
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DiskLib_IsVMFSSparseSupported: vmfssparse is not supported on /vmfs/volumes/DATASTORE_UUID/VM_NAME: f532.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE   : DiskLibCreateCreateParam: Selecting the default child type as SeSparse for /vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-LIB_CREATE   : DiskLibCreateCreateParam: seSparse grain size is set to 8 for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-000005.vmdk'
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranchDisk failed for '/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME.vmdk' : A required file was not found (7).
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: DISKLIB-VMFS  : "/vmfs/volumes/DATASTORE_UUID/VM_NAME/VM_NAME-flat.vmdk" : closed.
YYYY-MM-DD HH:MM:SS| vcpu-0| I125: SNAPSHOT: SnapshotBranch failed: A required file was not found (7).
...

Causa

Het probleem kan zich voordoen wanneer er zwevende tijdelijke snapshot-descriptorbestanden zijn in de map van het dataarchief van de virtuele machine. Deze snapshot descriptorbestanden worden weergegeven als ####.-000001.vmdk, ####.-000001-sesparse.vmdk en ####.-000001-ctk.vmdk.

Resolución

De stappen voor het verwijderen van de zwevende tijdelijke snapshotbeschrijvingsbestanden worden beschreven in VMware Knowledge Base 80246.

https://kb.vmware.com/s/article/80246 Deze hyperlink brengt u naar een website buiten Dell Technologies.  
  1. Blader door de datastore van de getroffen VM om de tijdelijke descriptorbestanden te identificeren. De naam kan worden weergegeven als: 
    • ####-000001.vmdk
    • ####-000001-sesparse.vmdk
    • ####-000001-ctk.vmdk 
  2. Identificeer een map met voldoende ruimte om de tijdelijke descriptorbestanden te verplaatsen en een nieuwe map te maken
    • vmfs/volumes/VM_####_DATASTORE5/FOLDERNAME/
  3. De tijdelijke descriptorbestanden verplaatsen naar een nieuwe map
  4. Maak een snapshot van de VM envdate snapshot die met succes is gemaakt.
  5. Verwijder alle snapshots met de optie "Delete All Snapshots".
  6. Valideer de verwijderde snapshot.
  7. Valideer dat er geen descriptorbestanden zijn in de map VM datastore.
  8. Laat de geplande vProxy back-ups uitvoeren.

Información adicional

Productos afectados

NetWorker
Propiedades del artículo
Número del artículo: 000196313
Tipo de artículo: Solution
Última modificación: 23 oct 2024
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.