PowerMax e VMware Storage vMotion
Resumen: Este artigo descreve as operações do vMotion da perspectiva do PowerMax.
Síntomas
- Armazenamento é PowerMax
- O Storage vMotion está em uso.
- O vMotion pode estar copiando mais lentamente do que o esperado
- O host pode estar registrando erros relacionados ao vMotion.
Causa
O vMotion é um produto VMware que usa primitivos XCOPY do VAAI para descarregar solicitações de cópia no armazenamento, o que pode conservar recursos de host e acelerar as transferências de dados.
O processo pode ser resumido da seguinte forma:
- O vMotion é instruído a mover mais de 256 KB de dados de um local para outro.
- O vMotion envia solicitações de cópia ao PowerMax.
- O total de dados a serem movidos é dividido em fragmentos pelo vMotion.
- O PowerMax permite que as solicitações sejam movidas até 16 MB por extensão, mas o vMotion assume como padrão fragmentos de 4 MB. Isso pode ser aumentado para um máximo de 16 MB usando as Regras de declaração.
- O PowerMax cria uma sessão XCOPY entre o dispositivo de origem e destino (que pode ser o mesmo dispositivo).
- O PowerMax agrupa os fragmentos em "extensões" e coloca cada extensão em uma tabela XCOPY.
- O PowerMax confirma o recebimento dessa parte para o vMotion.
- Aqui, o vMotion acredita que a cópia está completa.
- As etapas de 4 a 5 são repetidas para cada solicitação de cópia do vMotion.
- Se o PowerMax detectar um problema em uma solicitação de cópia, a solicitação será rejeitada. O vMotion tem como padrão copiar a parte usando leituras ou gravações normais do host se nenhuma das repetições for bem-sucedida.
- O PowerMax funciona por meio da tabela XCOPY, movendo os dados da origem para o destino de modo assíncrono a partir da solicitação de cópia do vMotion.
- As funções de leitura ou gravação no PowerMax executam cópia.
- Isso deve ser concluído rapidamente, mas poderá ser copiado mais lentamente se forem necessários recursos avançados para a E/S contínua do host.
Nota: Todo XCOPY pausa se o SRP (Storage Resource Pool, Pool de Recursos de Armazenamento) atinge a capacidade de reserva (normalmente os últimos 10% do SRP, o que significa que o SRP está mais de 90% usado). Essa situação pode deixar dados não copiados no local de destino até que o SRP não esteja mais na capacidade de reserva.
- O VMware libera os dados da solicitação de cópia para uso do host no local de destino.
- Se a operação inicial do vMotion foi uma movimentação em vez de uma cópia e o UNMAP estiver habilitado, o host emitirá comandos UNMAP para a trilha de origem fora do protocolo vMotion.
Resolución
A VMware detalha os requisitos para o uso do Storage vMotion com VAAI XCOPY em seu artigo VMware vSphere APIs: Integração de array (VAAI).
Requisitos do PowerMax para uso do vMotion:
- Os dispositivos de origem e destino não devem estar envolvidos no SRDF/Metro (ativo/ativo)
- Os dispositivos de origem e destino não devem estar envolvidos em sessões do SnapVX.
Conforme indicado na etapa 5 da seção Causa acima, o PowerMax rejeitará solicitações de cópia se a solicitação não for compatível. Os motivos comuns de rejeição incluem:
- Não é possível fazer a cascata
- A cópia de dados para o primeiro destino deve ser concluída antes que os mesmos dados possam ser copiados do outro destino. Se a primeira cópia ainda não estiver concluída (ainda na tabela XCOPY), uma solicitação de cópia de qualquer parte desses mesmos dados para outro local será rejeitada.
- Extensões não alinhadas:
- O endereço de bloco lógico (LBA) para o início e o fim do fragmento deve estar no primeiro bloco de uma trilha de 128 KB, e o LBA no final da parte deve estar no último bloco de uma trilha de 128 KB. Isso deve ser verdadeiro na origem e no destino para que a solicitação de cópia seja aceita.
- A solicitação de cópia deve conter dados reais. Se a solicitação contiver apenas extensões com contagens de blocos iguais a zero, ela será rejeitada.
- A solicitação de cópia deve conter pelo menos 256 (0x100) blocos de dados em uma extensão. Quantidades menores de dados são rejeitadas.
Se precisar de mais ajuda para solucionar os problemas acima, entre em contato com o suporte técnico da Dell ou com seu representante de serviço autorizado e forneça o número deste artigo da base de conhecimento.