NetWorker-modul for databaser og applikasjoner: DB2 online backup mislykkes med feil "SQL2413N online backup er ikke tillatt fordi databasen ikke kan gjenopprettes"

Resumen: NMDA DB2 online backup mislykkes med feil nsrdasv: kan ikke sikkerhetskopiere eksempeldatabase på grunn av feil ved sikkerhetskopieringsforespørsel SQLCODE: -2413, er SQL2413N sikkerhetskopiering online ikke tillatt fordi databasen ikke kan gjenopprettes. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

En NMDA-sikkerhetskopiering (NetWorker Module for Databases and Applications) som utføres enten fra NetWorker Management Console (NMC) eller fra DB2-serveren, mislykkes med følgende feilmelding:
«SQL2413N sikkerhetskopiering på Internett er ikke tillatt fordi databasen ikke kan gjenopprettes».

Causa

Hver DB2-database som er installert er i sirkulær logging som standard. Online sikkerhetskopiering er ikke mulig i sirkulær logging.

Resolución

Aktiver DB2-arkivlogging.

Eksempel på trinn som vises nedenfor, er for en DB2-database kalt 'Db4'.
1. Åpne DB2-kommandovinduet på klienten.
2. Sjekk DB2-loggingsmodus ved hjelp av kommando som vist i skjermbildet nedenfor: 
image.png

3. Oppdater annen logarchmeth og logarchopt enn verdien "AV". Eksempel:
image.png
 
4. Ved hjelp av NMDA kan DB2-transaksjonslogger arkiveres automatisk til Data Domain-lagring. Se NMDAs administrasjonsveiledning for detaljerte trinn.
 

Información adicional

Administrasjonsveiledningen for NetWorker-modulen for databaser og applikasjoner er tilgjengelig fra Dell Support på følgende adresse: https://www.dell.com/support/home/product-support/product/networker-module-for-databases-and-applications/docs.
Propiedades del artículo
Número del artículo: 000191364
Tipo de artículo: Solution
Última modificación: 09 mar 2022
Versión:  1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.