Il backup di NetWorker vProxy ha esito negativo con errore "RPC error: Impossibile connettersi all'host " e "Err: 5037-Impossibile risolvere l'indirizzo IP dall'host "

Resumen: L'integrazione NetWorker VMware Protection (NVP) è configurata con l'appliance vProxy. Il deployment di vProxy ha riscontrato alcuni problemi con la risoluzione dei nomi e il DNS. I backup delle virtual machine (VM) per alcune macchine virtuali hanno esito negativo con un messaggio di errore di risoluzione dei nomi non valida. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Dal file /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR:  [1268:7F4794001E30] ddp_connect_with_config_internal() failed, Hostname: 110DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:YYYY-MM-DDTHH:MM:SSZ ERROR:  [1268:7F4794001E30] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T07:08:43Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
---- Skipping Lines ----
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T13:59:20Z ERROR:  [1268:7F4778001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:06:29Z INFO:   [1268:7F476C001C80] ddcl_nfs_open_tcp - Timed out trying to resolve the hostname: DD###_T4
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR:  [1268:7F476C001C80] ddp_connect_with_config_internal() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0
./opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-boost.log:2023-11-01T14:15:29Z ERROR:  [1268:7F476C001C80] ddp_connect_with_config() failed, Hostname: DD###_T4, Err: 5037-Cannot resolve IP address from Host DD###_T4-failover for ip family 0

Da /nsr/logs/daemon.raw:
71193 MM/DD/YYYY HH:MM:SS AM  0 0 0 4988 4616 0 my_networker_server nsrd NSR info Media Info: Failed to start nsrsnmd on host my_storagenode_name, error `RPC error: Failed to connect to host 'my_storagenode_name': Remote system error - No connection could be made because the target machine actively refused it.
 
Consultare l'articolo Dell 22793, NetWorker: Come utilizzare nsr_render_log (in inglese)

Causa

Problema di risoluzione dei nomi a livello di host vProxy

Resolución

Aggiungere manualmente l'indirizzo IP, l'FQDN, il nome breve di vCenter, Data Domain, NetWorker e storage node in /etc/hosts dell'host vProxy.

Avviare i backup delle VM vProxy ora.
  1. Accedere alla sessione PuTTY vProxy come amministratore, quindi passare a root:
sudo su - root
  1. Eseguire il seguente comando per creare una voce /etc/host
# echo "IP_of_vCenter FQDN_of_vCenter ShortName_of_vCenter" >> /etc/hosts
ESEMPIO:
# echo "10.10.10.10 myvcenter.abc.com myvcenter" >> /etc/hosts
# echo "IP_of_DD FQDN_of_DD ShortName_of_DD" >> /etc/hosts
# echo "IP_of_NWServer FQDN_of_NWServer ShortName_of_NWServer" >> /etc/hosts
# echo "IP_of_StorageNode FQDN_of_StorageNode ShortName_of_StorageNode" >> /etc/hosts

Productos

NetWorker Family
Propiedades del artículo
Número del artículo: 000219162
Tipo de artículo: Solution
Última modificación: 23 oct 2024
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.