NetWorker: How to remove duplicated default resources from configuration
Resumen: This Article describes a method to find and safely remove default objects which could have been mistakenly created in the NetWorker configuration.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
- Duplicated default resources such as Default pool, Server Protection policy, or Forever Incremental schedule
- Observable errors may reference duplicates, such as:
"Unable to log an audit message. The audit log daemon nsrlogd running on host '<nsrserverhost>' is not configured to accept messages from this client. Check the audit log configuration."
Causa
- When NetWorker services start, checks are made in the resource database to ensure that all Default resources are present; if they are missing, such as if the server is started with the nsrdb directory containing the configuration objects missing or empty, they are automatically re-created with file names partially reflecting their creation time.
- If the nsrdb contents containing the same default items are, then copied into such a folder, there will be two instances of the default items of the same name and type since their filenames are different.
- This is most likely to occur during server disaster recovery, upgrade, rehosting, or reinstallation.
Resolución
- Identify the resource identifiers or filenames with common sections:
- RAP resource identifier: 9th-12th decimal-separated field, for example 4.0.92.34.0.0.0.0.189.228.121.101.10.3.37.150
- RAP filename: 17th-24th characters, e.g 04005c2200000000bde479650a032596
- Shutdown NetWorker services
- Move all such files to a temporary location and review the contents
- Once satisfied, restart NetWorker services and review active configuration
Productos afectados
NetWorker FamilyPropiedades del artículo
Número del artículo: 000222887
Tipo de artículo: Solution
Última modificación: 08 abr 2024
Versión: 1
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.