NMC: Adding Data Domain system reports "The Data Domain System is already defined"

Resumen: Not able to see the Data Domain system in the NMC Enterprise tab, but able to see the Data domain system details in the Devices tab of NMC Administrator. Also, able to see the details of the Data Domain system in nsradmin. When trying to add the Data domain system in the NMC Enterprise tab, getting Error as "The Data Domain System is already defined". ...

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Síntomas

The NetWorker server is configured with one or more existing Data Domains.
The NetWorker Management Console (NMC) Enterprise tab does not list one (or more) of the Data Domain systems. 
While adding the Data Domain in the NMC Enterprise tab, the following error appears.
an error appears in the NMC stating the Data Domain System is already defined 

The Data Domain System "DATA_DOMAIN_NAME" is already defined

Causa

The cause of this symptom can vary. A common cause is that NetWorker was reinstalled with a fresh NMCDB. The NMC folder (or its subsequent nmcdb folder) was renamed/removed prior to reinstalling/upgrading NetWorker.

Linux: /nsr/nmc
Windows: <Install Drive>:\Program Files\EMC NetWorker\Management

Resolución

Follow the below steps to solve the issue:

  1. Log in to the NetWorker Management Console (NMC) using the default Administrator account (or another account with Application Administrator privileges).
  2. From the NMC Enterprise screen, connect to the NetWorker server.
  3. Go to the Devices->Devices tab.
  4. Right-click in the Devices window and select New Device Wizard.
  5. Create a new Data Domain type device using the existing Data Domain system:

Creating a Data Domain device in the NMC, using an existing Data Domain

NOTE: The configuration of the device does not matter. You can configure this device for future use, or delete it after completing all the steps in this KB. The process is only needed to repopulate the NMC Enterprise tab with the Data Domain system. Repeat this same process for each Data Domain system that is missing from the NMC Enterprise tab, but exists on the NetWorker server.
  1. Restart the NMC server service:

Linux: sudo systemctl restart gst
Windows (Administrator PowerShell): net stop gstd ; net start gstd

  1. Launch the NMC and confirm that the Data Domain system is visible under the Enterprise tab.

Productos afectados

NetWorker Family, NetWorker
Propiedades del artículo
Número del artículo: 000227619
Tipo de artículo: Solution
Última modificación: 29 nov 2024
Versión:  1
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