Data Protection Advisor (DPA): Błąd podczas aktualizacji lub instalacji "Could not initialize class java.awt.Toolkit"

Resumen: Błąd podczas aktualizacji lub instalacji "Could not initialize class java.awt.Toolkit"

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Podczas próby uaktualnienia lub instalacji DPA na serwerze aplikacji lub magazynu danych w systemie Linux instalator natychmiast zakończy pracę z następującym błędem w wierszu poleceń:

Stack Trace:
java.lang.NoClassDefFoundError: Could not initialize class java.awt.Toolkit
        at java.awt.Component.<clinit>(Component.java:593)
        at com.zerog.ia.installer.actions.InstallUninstaller.bv(Unknown Source)
        at com.zerog.ia.installer.actions.InstallUninstaller.installSelf(Unknown Source)
        at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
        at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
        at com.zerog.ia.installer.GhostDirectory.install(Unknown Source)
        at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)
        at com.zerog.ia.installer.Installer.install(Unknown Source)
        at com.zerog.ia.installer.LifeCycleManager.consoleInstallMain(Unknown Source)
        at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
        at com.zerog.ia.installer.Main.main(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at com.zerog.lax.LAX.launch(Unknown Source)
        at com.zerog.lax.LAX.main(Unknown Source)

Aplikacja została nieoczekiwanie zamknięta: Wywołanie tej aplikacji Java spowodowało wyjątek InvocationTargetException. Aplikacja zostanie zamknięta. (LAX)

Causa

Data Protection Advisor działa zgodnie z założeniami.
Niektóre 64-bitowe biblioteki systemowe nie zostały zainstalowane w systemie operacyjnym


Aby zidentyfikować brakujące biblioteki systemowe, można uruchomić następujące polecenie w pliku libawt_xawt.so, który znajduje się w install_dir<>/services/_jre/lib/amd64/:
 
ldd libawt_xawt.so
Poniżej znajduje się przykład danych wyjściowych polecenia:
[root@App_hostname amd64]# ldd libawt_xawt.so
        linux-vdso.so.1 =>  (0x00007fffbef89000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9b22f53000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f9b22c50000)
        libawt.so => /opt/emc/dpa/services/_jre/lib/amd64/./libawt.so (0x00007f9b22980000)
        libXext.so.6 => /lib64/libXext.so.6 (0x00007f9b2276e000)
        libX11.so.6 => /lib64/libX11.so.6 (0x00007f9b2242f000)
        libXrender.so.1 => not found  <<
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f9b2222b000)
        libXtst.so.6 => not found  <<
        libXi.so.6 => not found  <<
        libjava.so => /opt/emc/dpa/services/_jre/lib/amd64/./libjava.so (0x00007f9b21ffb000)
        libjvm.so => not found  <<
        libc.so.6 => /lib64/libc.so.6 (0x00007f9b21c37000)
        /lib64/ld-linux-x86-64.so.2 (0x000055614bbdf000)
        libjvm.so => not found
        libxcb.so.1 => /lib64/libxcb.so.1 (0x00007f9b21a0e000)
        libjvm.so => not found
        libverify.so => /opt/emc/dpa/services/_jre/lib/amd64/./libverify.so (0x00007f9b217fe000)
        libXau.so.6 => /lib64/libXau.so.6 (0x00007f9b215fa000)
        libjvm.so => not found

Resolución

Brakujące biblioteki będą musiały zostać zainstalowane w systemie operacyjnym, aby umożliwić pomyślne zakończenie pracy instalatora.  Narzędzia takie jak Yum lub Yast mogą być użyte do zainstalowania brakujących bibliotek.
Po zakończeniu instalacji brakujących bibliotek można ponownie uruchomić następujące polecenie, aby potwierdzić, że wszystkie wymagane biblioteki są zainstalowane:
ldd libawt_xawt.so
Skontaktuj się z działem pomocy technicznej firmy Dell EMC, aby uzyskać szczegółowe informacje.

Información adicional

Productos afectados

Data Protection Advisor
Propiedades del artículo
Número del artículo: 000057018
Tipo de artículo: Solution
Última modificación: 17 abr 2026
Versión:  6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.