AppSync: Postgres upgrade fails
Resumen: AppSync: Postgres upgrade fails
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Postgres is being upgraded per KB 000504125, and it fails to upgrade Postgres.
The appsync_dbupgrade.log will show:
Command.run(): C:\Users\userid\AppData\Local\Temp\2\011266.tmp\executeScriptTmp0.bat:stdout [Failure, exiting]
Command.complete(): process completed with exit code: 1
Command.complete(): process completed with exit code: 1
The pg_upgrade_utility.log will show:
command: xcopy /e /y /q /r "E:\EMC\AppSync\jboss\datastore\data/pg_clog" "E:\EMC\AppSync\NewDatastore\data/pg_clog\" >> "pg_upgrade_utility.log" 2>&1
Invalid drive specification
0 File(s) copied
Invalid drive specification
0 File(s) copied
Note: The pg_upgrade_utility.log located in %AppData% will be removed when clicking OK when the failed upgrade message is presented during the upgrade dialog. Therefor this file must be collected before clicking OK and existing the upgrade dialog.
Note: The AppSync database resides in a non-default location, the E: drive in this example.
Causa
The trigger is a permission related issue for which the precise cause is not known.
The upgrade utility is being run as administrator and the user who is logged in when the upgrade utility is run as administrator via the right click method is a Domain administrator which exists in the local admin group which has full rights to the E: drive.
Regardless, should you use procmon to debug, you will find permission errors for the logged in user to the E: drive.
The upgrade utility is being run as administrator and the user who is logged in when the upgrade utility is run as administrator via the right click method is a Domain administrator which exists in the local admin group which has full rights to the E: drive.
Regardless, should you use procmon to debug, you will find permission errors for the logged in user to the E: drive.
Resolución
Explicitly provide full administrative right to the E: drive for the specific user that is logged in when running the upgrade process.
Productos afectados
AppSyncProductos
AppSyncPropiedades del artículo
Número del artículo: 000057208
Tipo de artículo: Solution
Última modificación: 17 abr 2026
Versión: 7
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.