NVE: Сбой развертывания при установке языковых пакетов NetWorker (11 из 29)

Resumen: Устройство NetWorker Virtual Edition (NVE) развертывается в среде. Происходит сбой диспетчера установки NetWorker во время установки языковых пакетов NetWorker.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Диспетчер установки NetWorker отображает ошибку «Установка языковых пакетов NetWorker (11 из 29)».  При повторной попытке в NetWorker Installation Manager на том же шаге произойдет сбой. Переменная /space/avamar/var/avi/server_log/avinstaller.log.0 Показывает:

INFO: PollMessageSender sent: <UpdateMessage><TaskName>Installing NetWorker Language Packs (11 of 29)</TaskName><ProcessKey>nve-config20210209Feb021612938761</ProcessKey><ProcessInstanceId>nve-config20210209Feb021612938761.10007</ProcessInstanceId><TaskId>10109</TaskId><Timestamp>YYYYY/MM/DD-HH:MM:SS.00648</Timestamp><Content>Installing NetWorker Language Packs (11 of 29) Failed</Content><Transition behavior="Retry Installing NetWorker Language Packs (11 of 29)">Call EMC Support</Transition></UpdateMessage>
Month DD, YYYY HH:MM:SS PM com.avamar.avinstaller.process.TaskTimeManager stopTimer
INFO: startTime: 0

Переменная /data01/avamar/repo/temp/*/tmp/workflow.log Показывает:

YYYY-MM-DD HH:MM:SS (+0000) 69935412443820 INFO: - - - - - - - BEGIN(stderr output) - - - - - - -
YYYY-MM-DD HH:MM:SS (+0000) 69935412443820 INFO: hostname: Host name lookup failure
YYYY-MM-DD HH:MM:SS (+0000) 69935412443820 INFO: - - - - - - - END
YYYY-MM-DD HH:MM:SS (+0000) 69935412443820 INFO: "hostname -f", exit status=1
YYYY-MM-DD HH:MM:SS (+0000) 69935412443820 INFO: Tools.get_system_hostname: cmd="hostname -f" status=1 stdout=[] stderr=["hostname: Host name lookup failure\n"]
В /data01/avamar/repo/temp/*/tmp/err.log отображается следующее:
YYYY-MM-DD HH:MM:SS (-0400) 70219139119780 ERROR: ERROR: getaddrinfo: Name or service not known

Causa

Система доменных имен (DNS) NVE неправильно настроена для обеспечения разрешения имен в среде. В соответствии с разделом «Проверка конфигурации DNS» руководства по развертыванию Dell EMC NetWorker Virtual Edition:

Прежде чем развертывать NVE, убедитесь, что DNS-сервер правильно настроен для имени хоста и IP-адреса сервера vCenter и устройства NVE. Неправильное разрешение имен приводит к ошибкам выполнения и проблемам конфигурации.

Resolución

1. Подключитесь к NVE по SSH в качестве администратора.

ПРИМЕЧАНИЕ. Если сетевая плата недоступна по протоколу SSH, к ней можно подключиться с помощью веб-консоли vSphere, а в vSphere можно войти непосредственно в качестве пользователя root.

2. Переключитесь на учетную запись root. sudo su -
3. Проверьте, какие DNS-серверы (если таковые имеются) определены в файле resolv.conf NVE: cat /etc/resolv.conf
4. Измените файл /etc/sysconfig/network/config файл, содержащий корректные DNS-серверы и поисковый суффикс,

a. Найдите строку, содержащую NETCONFIG_DNS_STATIC_SERVERS, и добавьте DNS-серверы, например:
NETCONFIG_DNS_STATIC_SERVERS="192.168.9.100 10.10.10.2"

b. Найдите строку, содержащую NETCONFIG_DNS_STATIC_SEARCHLIST, и добавьте все домены поиска. Обычно сюда входят доменное имя NVE и любые дополнительные домены DNS-серверов.

NETCONFIG_DNS_STATIC_SEARCHLIST="amer.lan"

5. Сохраните файл и убедитесь, что изменения применены к файлу /etc/resolv.confcat /etc/resolv.conf

ПРИМЕЧАНИЕ. Если изменения не были применены, выполните команду: netconfig update -f

6. Убедитесь, что вы можете проверить связь с DNS-сервером и разрешить проблему:

ping DNS_SERVER_IPADDRESS
nslookup DNS_SERVER_IPADDRESS

7. Когда DNS начнет отвечать должным образом, вернитесь в пользовательский интерфейс установки NVE и повторите задачу. 

Información adicional

Productos afectados

NetWorker
Propiedades del artículo
Número del artículo: 000192766
Tipo de artículo: Solution
Última modificación: 22 oct 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.