Avamar. Сбой сборки мусора с MSG_ERR_TRYAGAINLATER

Resumen: Начиная с версии 7.x, где резервное копирование разрешено во время обслуживания сборки памяти, иногда может появляться сообщение «MSG_ERR_TRYAGAINLATER».

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Задание обслуживания сборки мусора Avamar завершается с ошибкой MSG_ERR_TRYAGAINLATER.

 

Чтобы проверить проблему, выполните следующие действия.

  1. status.dpn Показывает:

admin@avamarhost:~/>: status.dpn
...
Last GC: finished Mon Dec 23 06:08:00 2013 after 03m 05s >> recovered 0.00 KB (MSG_ERR_TRYAGAINLATER)

 

  1. Проверьте, используя команду dumpmaintlogs команду:

admin@avamarhost:~/>: dumpmaintlogs --types=gc --days=1
...
2013/12/23-12:08:00.9673 {0.0} <4202> failed garbage collection with error MSG_ERR_TRYAGAINLATER

 

  1. При необходимости это может быть проверено службой поддержки Avamar в журналах сервера Avamar.

 

Causa

Это ожидаемое поведение, которое происходит при добавлении новых данных в Avamar из резервных копий.

 

Когда контейнеры хранилища, или «полосы» в Avamar, разделяются на две части, это называется разделением индексной полосы.

Это происходит редко, редко и только после достижения определенных интервалов емкости в зависимости от размера, количества, версии узла и т. д. Эта задача обслуживания не может быть выполнена во время сборки мусора.

 

Если полоса индекса разбивается при попытке выполнения определенных операций GC, сборка мусора завершает работу с MSG_ERR_TRYAGAINLATER.

Если полоса индекса выполняет сборку мусора и ее необходимо разделить, она ожидает завершения операций сборки мусора.

 

Индексные полосы на сетке, как правило, разделяются примерно в один и тот же период времени, что и друг друга на различных узлах. Иногда это может занять несколько дней.

 

Resolución

Avamar работает должным образом.
После завершения разделения полосы индекса сборка мусора возобновляется.

 

Временное решение проблемы — не запускать резервное копирование во время GC.

 

Información adicional

  • Это не происходит в сетке, которая находится в «стабильном состоянии» (имеет стабильное или уменьшающееся использование емкости), так как все полосы данных, которые должны существовать, уже существуют.
  • Это не происходит в сети, которая заполнилась и с тех пор уменьшила емкость (без расширения новыми узлами). Это связано с тем, что все полосы, которые можно создать на сетке, уже существуют.
  • Такая ситуация может возникнуть после добавления узла и наличия дополнительной емкости для дальнейшего разделения полос данных.
  • Эта проблема может время от времени повторяться и с большей вероятностью будет наблюдаться в сетках Avamar, в которых наблюдается устойчивый рост объемов данных или которые недавно были расширены за счет добавления дополнительных узлов.
  • Такое поведение может сохраняться в течение нескольких дней.

 

Productos afectados

Avamar

Productos

Avamar
Propiedades del artículo
Número del artículo: 000163002
Tipo de artículo: Solution
Última modificación: 23 abr 2025
Versión:  9
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.