Dell EMC Unity: las tareas programadas de uDoctor causan una alta utilización de CPU (corregible por el usuario)
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Todos los días al mismo tiempo La utilización en el procesador de almacenamiento primario aumenta hasta un 90-100 % y permanece por alrededor de 15 minutos.
Causa
El equipo de CloudIQ descubrió que un complemento de recopilación de datos de servicio específico puede activar varios comandos de PSQL en ocasiones.
Cuando esto ocurre, las consultas de PSQL causan una utilización masiva de CPU en el procesador de almacenamiento primario, que es el SP responsable de ejecutar uDoctor.
Nota: Esto no ocurre cuando se genera y recopila la recopilación de datos de servicio manualmente, solo afecta a las tareas programadas de uDoctor, como las que se generan a partir de registros diarios generados para CloudIQ.
Cuando esto ocurre, las consultas de PSQL causan una utilización masiva de CPU en el procesador de almacenamiento primario, que es el SP responsable de ejecutar uDoctor.
Nota: Esto no ocurre cuando se genera y recopila la recopilación de datos de servicio manualmente, solo afecta a las tareas programadas de uDoctor, como las que se generan a partir de registros diarios generados para CloudIQ.
Resolución
La solución para este problema ya está implementada y se incluirá en la próxima versión 5.0.3 del ambiente operativo de Unity.
Para obtener más información sobre las versiones de Dell EMC UnityOE y su versión, consulte el número de artículo 000489694.
También hay una solución alternativa que se podría aplicar para mediar el problema hasta que se libere el código.
Para obtener ayuda para implementar esta solución alternativa, comuníquese con el soporte técnico y mencione el número de artículo 000541286.
Para obtener más información sobre las versiones de Dell EMC UnityOE y su versión, consulte el número de artículo 000489694.
También hay una solución alternativa que se podría aplicar para mediar el problema hasta que se libere el código.
Para obtener ayuda para implementar esta solución alternativa, comuníquese con el soporte técnico y mencione el número de artículo 000541286.
Información adicional
Para confirmar que este es el problema que está experimentando, utilice los siguientes comandos en la CLI de Unisphere en un terminal SSH de su elección:
En EMCSystemLogFile.log
Comando de métricas de UEMCLI (histórico):
Comando de métricas de UEMCLI (en tiempo real):
En EMCSystemLogFile.log
service@spb:~# tailf 00_emc_backend_log_shared/EMCSystemLogFile.log | grep -i udoctor
"2020-02-16T13:03:12.155Z""Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Solo información interna. Se eliminó el archivo PSM "udoctor". :: Category=System Component=psm TimeZone=UTC
"2020-02-17T13:03:12.944Z""Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Información interna solamente. Se eliminó el archivo PSM "udoctor". :: Categoría=Componente del sistema=psm Zona Horaria=UTC
"2020-02-16T13:03:12.155Z""Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Solo información interna. Se eliminó el archivo PSM "udoctor". :: Category=System Component=psm TimeZone=UTC
"2020-02-17T13:03:12.944Z""Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Información interna solamente. Se eliminó el archivo PSM "udoctor". :: Categoría=Componente del sistema=psm Zona Horaria=UTC
Comando de métricas de UEMCLI (histórico):
service@spb:~# uemcli -no /metrics/value/hist -path sp.*.cpu.summary.utilization show -interval 60 -from "2020-02-16 12:59:00" -to "2020-02-16 13:59:00"
Timestamp | | de almacenamiento de sp |summary
| | de CPU
| %
de utilidad --------------------+----------+-------
2020-02-16 13:02:00 |spa | 13,93
| | pb 66.47
2020-02-16 13:03:00 |spa | 12,49
| | pb 90.96
2020-02-16 13:04:00 |spa | 12,94
| |spb 92.63
2020-02-16 13:05:00 |spa | 11,91
| | pb 93.29
2020-02-16 13:06:00 |spa | 5,072
| |spb 92.28
2020-02-16 13:07:00 |pa | 2,497
| |spb 90.06
2020-02-16 13:08:00 |pa | 2,452
| | pb 92.38
2020-02-16 13:09:00 |pa | 2,527
| |spb 95.68
2020-02-16 13:10:00 |pa | 2.441
| |spb 98.36
2020-02-16 13:11:00 |spa | 2,845
| | pb 97.170
2020-02-16 13:12:00 |pa | 2,466
| | pb 97.096
2020-02-16 13:13:00 |pa | 2,479
| | pb 97.732
2020-02-16 13:14:00 |spa | 2,469
| | pb 98.023
2020-02-16 13:15:00 |spa | 2,362
| | pb 96.391
2020-02-16 13:16:00 |spa | 2,697
| |spb 65.053
Timestamp | | de almacenamiento de sp |summary
| | de CPU
| %
de utilidad --------------------+----------+-------
2020-02-16 13:02:00 |spa | 13,93
| | pb 66.47
2020-02-16 13:03:00 |spa | 12,49
| | pb 90.96
2020-02-16 13:04:00 |spa | 12,94
| |spb 92.63
2020-02-16 13:05:00 |spa | 11,91
| | pb 93.29
2020-02-16 13:06:00 |spa | 5,072
| |spb 92.28
2020-02-16 13:07:00 |pa | 2,497
| |spb 90.06
2020-02-16 13:08:00 |pa | 2,452
| | pb 92.38
2020-02-16 13:09:00 |pa | 2,527
| |spb 95.68
2020-02-16 13:10:00 |pa | 2.441
| |spb 98.36
2020-02-16 13:11:00 |spa | 2,845
| | pb 97.170
2020-02-16 13:12:00 |pa | 2,466
| | pb 97.096
2020-02-16 13:13:00 |pa | 2,479
| | pb 97.732
2020-02-16 13:14:00 |spa | 2,469
| | pb 98.023
2020-02-16 13:15:00 |spa | 2,362
| | pb 96.391
2020-02-16 13:16:00 |spa | 2,697
| |spb 65.053
Comando de métricas de UEMCLI (en tiempo real):
service@spb:~# uemcli -no /metrics/value/rt -path sp.*.cpu.summary.utilization show -interval 10
Timestamp | | de almacenamiento de sp |summary
| | de CPU
| %
de utilidad --------------------+----------+-------
2020-02-17 13:03:20 |spa | 0,929
| |spb 90.810
2020-02-17 13:03:30 |pa | 1,928
| |spb 90.980
2020-02-17 13:03:40 |spa | 2.417
| |spb 90.537
2020-02-17 13:03:50 |spa | 1.912
| |spb 91.601
2020-02-17 13:04:00 |pa | 2.124
| |spb 93.625
2020-02-17 13:04:10 |spa | 3,828
| |spb 92.191
Timestamp | | de almacenamiento de sp |summary
| | de CPU
| %
de utilidad --------------------+----------+-------
2020-02-17 13:03:20 |spa | 0,929
| |spb 90.810
2020-02-17 13:03:30 |pa | 1,928
| |spb 90.980
2020-02-17 13:03:40 |spa | 2.417
| |spb 90.537
2020-02-17 13:03:50 |spa | 1.912
| |spb 91.601
2020-02-17 13:04:00 |pa | 2.124
| |spb 93.625
2020-02-17 13:04:10 |spa | 3,828
| |spb 92.191
Productos afectados
Dell EMC Unity FamilyProductos
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F
, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
...
Propiedades del artículo
Número del artículo: 000058581
Tipo de artículo: Solution
Última modificación: 20 oct 2025
Versión: 4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.