Isilon OneFS 8.0: No se puede instalar el paquete de firmware: /var/patch/backup: no es un directorio

Resumen: La instalación del paquete de firmware no se completó.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Durante la instalación del paquete de firmware, la instalación no se completa y genera resultados como los siguientes:

# isi upgrade patches list

Patch Name                                          Description                                           Status
----------------------------------------------------------------------------------------------------------------------------------
IsiFw_Package_v9.3.5 Package Name  : IsiFw Package v9.3.5 2017-04-04 To... Installing

El estado se mostrará como Instalando indefinidamente.

 

Mira las últimas líneas de /var/log/isi_pkg de cada nodo, y debería ver el siguiente error:

# isi_for_array -s 'tail -50 /var/log/isi_pkg'
.........
2017-05-28T13:31:56-05:00 <3.6> node-1 isi_pkg[16306]: Starting task for request 'INSTALL', task 'INSTALL_INIT', hash '2693c810637d37a02ee9cb57a9d01d3d'
2017-05-28T13:31:59-05:00 <3.6> node-1 isi_pkg[16306]: Running requirements file first for IsiFw_Package_v9.3.5..
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: /var/patch/backup: is not a directory.
2017-05-28T13:31:59-05:00 <3.3> node-1 isi_pkg[16306]: install_init: Task encountered unknown failures

 

Este problema podría ocurrir para cualquiera de los paquetes de firmware, como IsiFw_Package_v9.3.5.tar o IsiFw_Package_v10.0.1.tar.

 

Causa

Partición montada en /var Requiere al menos un 40 % de espacio libre en disco para permitir la instalación de un parche grande, como un paquete de firmware. Si no tiene suficiente espacio libre en disco en /var, el nodo fallaría en la instalación con el siguiente error:

/var/patch/backup: is not a directory

 

Resolución

Reduzca el uso del disco en /var. Por lo general, es /var/log directorio que contendría archivos grandes que podrían necesitar ser truncados. Para determinar que:

  1. Determine qué nodo no tiene al menos un 40 % de espacio libre (la capacidad debe ser del 60 % o menos) en /var

    # isi_for_array -s 'df -h /var'
  2. Acceda mediante SSH al nodo como usuario raíz que no tiene suficiente espacio libre en /var

    # cd /var/log
    # du ./* | sort -n -r | head -n 10
  3. Crear un directorio de respaldo dentro de /ifs/data/Isilon_Support/ Para almacenar un respaldo de los archivos que se truncarán siga estos pasos:

    # mkdir /ifs/data/Isilon_Support/Node<node number>_VarLog_Backup
  4. Copie los archivos que está truncando en el nuevo directorio de respaldo:

    # cp  /ifs/data/Isilon_Support/Node_VarLog_Backup
  5. El resultado del paso 2 le daría los 10 archivos más grandes en /var/log. Puede truncar los archivos mediante el comando:

    # truncate -s 0 <filename>
  6. Vuelva a comprobar la partición para asegurarse de haber liberado al menos el 40 % (la capacidad debe ser del 60 % o menos) del espacio de disco en /var:

    # isi_for_array -s 'df -h /var'
  7. Una vez que haya liberado suficiente capacidad, vuelva a intentar la actualización fallida mediante el comando:

    # isi upgrade retry-last-action --nodes=<lnn of failed node>
  8. Espere 30 minutos para completar el proceso de actualización y compruebe que el paquete muestre el estado Instalado para:

    # isi upgrade patches list
    Patch Name                                               Description                                           Status
    ------------------------------------------------------------------------------------------------------------------
    IsiFw_Package_v10.0.1 Package Name  : IsiFw Package v10.0.1 2017-05-02 T... Installed

 

Si no sabe si los archivos se pueden truncar de manera segura o si no hay archivos grandes en /var/log pero /var Si la partición aún está demasiado llena, o la acción retry -last-no completa la instalación del parche, comuníquese con el soporte técnico para obtener asistencia y consulte este artículo de la base de conocimientos como referencia.

 

Productos afectados

Isilon
Propiedades del artículo
Número del artículo: 000170772
Tipo de artículo: Solution
Última modificación: 29 jul 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.