NVP vProxy: A Vista VMware Não é Atualizada e Todos os Backups de VM Falham

Resumen: O NetWorker VMware Protection (NVP) falha de forma consistente ou intermitente com "Fim do arquivo ou nenhuma entrada: Operação interrompida" ou "tempo limite (atraso de recepção de 3600 s) (atraso de envio de 3600 s)" registrado no log de sessão de backup. A atualização do VMware View da NetWorker Management Console (NMC) falha de forma consistente ou intermitente com o mesmo "Fim do ficheiro: Erro "Operação interrompida ou com tempo limite excedido" Este mesmo erro é observado no servidor NetWorker, daemon.log durante operações de inventário VMware (nsrvim). ...

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Síntomas

  • Os VMware vCenters são adicionados ao servidor NetWorker para a realização de backups do NetWorker VMware Protection vProxy.
  • Falha ao atualizar o separador Vista VMwareda NetWorker Management Console>>:   

VMware View — Erro ao obter informações do vCenter

Error fetching vCenter information for: vCenter_Name

Reason(s): Unable to fetch data from vCenter: End of file or no input: Operation interrupted or timed out (3600 s receive delay) (3600 s send delay).
  • O automatizado nsrvim processo utilizado para consultar o inventário do vCenter está a falhar. O daemon.log no servidor NetWorker relata:
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: nsrvim starting on NetWorker_Hostname (process 6252). 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Connecting to NetWorker on 'NetWorker_Hostname'. 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying NSR hypervisor resource 'vCenter_Hostname' 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Connecting to service at https://vCenter_Hostname/sdk 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Starting session with infrastructure services daemon. 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 5648 7592 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://vCenter_Hostname/sdk 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 7952 8524 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://vCenter_Hostname/sdk 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 3624 4728 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://vCenter_Hostname/sdk 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 6508 3964 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://vCenter_Hostname/sdk 
106637 MM/DD/YYYY HH:MM:SS AM/PM  1 3 0 2228 7760 0 NetWorker_Hostname nsrdisp_nwbg RAP notice job 'nsrvim' progress message: End of file or no input: Operation interrupted or timed out (3600 s receive delay) (3600 s send delay)
Linux: /nsr/logs/daemon.raw
Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
NetWorker: NetWorker: How to use nsr_render_log 
NetWorker: NetWorker: How to automatically render daemon.raw to daemon.log in real time 
  • Os backups de máquinas virtuais (VM) do vCenter falham com uma mensagem de erro semelhante relatada no log de sessões de backup:
MM/DD/YYYY HH:MM:SS AM/PM Failed to run nsrvim, error: Unable to fetch data from vCenter: End of file or no input: Operation interrupted or timed out (3600 s receive delay) (3600 s send delay).
MM/DD/YYYY HH:MM:SS AM/PM Failed to get work items. Will retry in 360 seconds.
MM/DD/YYYY HH:MM:SS AM/PM Starting nsrvim.
MM/DD/YYYY HH:MM:SS AM/PM Calling the nsrvim program to collect the inventory data.
MM/DD/YYYY HH:MM:SS AM/PM Setting default timeout 1800.
MM/DD/YYYY HH:MM:SS AM/PM Using a timeout of 1800 seconds for the nsrvim request. Minimum timeout is 360 seconds. Maximum timeout is 3600 seconds.
MM/DD/YYYY HH:MM:SS AM/PM Failed to run nsrvim, error: Unable to fetch data from vCenter: End of file or no input: Operation interrupted or timed out (3600 s receive delay) (3600 s send delay).
MM/DD/YYYY HH:MM:SS AM/PM Unable to fetch data from vCenter: End of file or no input: Operation interrupted or timed out (3600 s receive delay) (3600 s send delay)
MM/DD/YYYY HH:MM:SS AM/PM Action backup vmware-vproxy 'backup' with job id 1769899 is exiting with status 'failed', exit code 1
MM/DD/YYYY HH:MM:SS AM/PM Action has finished with failures.
Linux: /nsr/log/policy/Policy_Name/Workflow_Name
Windows: C:\Program Files\EMC NetWorker\nsr\logs\policy\Policy_Name\Workflow_Name
  • O servidor NetWorker pode alcançar a porta 443 no vCenter Server:
Windows (PowerShell): tnc vCenter_Hostname -port 443
Linux: curl -v vCenter_Hostname:443
NetWorker command: nsrports -t vCenter_Hostname -p 443
  • Os erros e sintomas descritos podem ser consistentes ou aparecer intermitentemente.

Causa

O erro retornado é que a operação foi interrompida ou atingiu o tempo limite. No entanto, o tempo limite é de 3600 s (1 hora) e o erro aparece antes de o limite de 1 hora ser ultrapassado. O processo está a ser interrompido.

  • Problema de firewall ou roteamento de rede.
  • O vCenter Server está a fechar a ligação antes da nsrvim O processo de inventário é concluído.

Cenário do Caso 1: A firewall está configurada com a Regra Adaptativa, que permite que o servidor NetWorker se ligue ao vCenter através de 443, mas fecha a ligação enquanto o NetWorker nsrvim está a inventariar o vCenter.

Cenário de Caso 2: o servidor vCenter está a enviar um segmento FIN durante o nsrvim aplicação PDU. 

O servidor NetWorker nsrvim é utilizado para consultar os servidores vCenter em busca de recursos VMware. Por padrão, esse processo é executado a cada 15 minutos no servidor NetWorker, sempre que uma "atualização" é feita no VMware View do NMC ou sempre que um trabalho de proteção de VM é iniciado.

Resolución

O administrador da rede ou da firewall tem de confirmar se existem regras de firewall que bloqueiem ou interrompam as ligações entre o servidor NetWorker e o servidor vCenter através da porta 443. Se houver alguma regra em vigor, desative-a temporariamente para ver se o problema foi resolvido no NetWorker. Se a desativação das regras permitir a atualização do VMware View e a conclusão dos backups do VMware, deverão ser feitas alterações no Firewall ou nas regras de roteamento para não descartar conexões entre o servidor NetWorker e o vCenter.

Os diagramas de portas e topologia de rede necessários são detalhados no Guia de Integração NetWorker VMware, disponível no Suporte da Dell em Informações de Suporte do NetWorker.

O administrador de rede também pode usar ferramentas de captura de pacotes (tcpdump, Wireshark) do servidor NetWorker e do vCenter. Quando o problema é reproduzido, reveja as capturas do pacote para ver se o servidor vCenter está a fechar a sessão de inventário.

Windows: servidor https://www.wireshark.org/Esse hiperlink direcionará você para um site fora da Dell Technologies.
Linux NetWorker e servidor vCenter: https://www.tcpdump.org/manpages/tcpdump.1.html Esse hiperlink direcionará você para um site fora da Dell Technologies.

tcpdump Exemplo de comando:

nohup tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap &
  • nohup indica que o comando é executado em segundo plano até que o PID seja encerrado com kill hostname.
  • -i especifica a interface, que você pode usar anyou especifique um nome de interface de rede do sistema, como eth0.
  • -s 0 especifica um comprimento de snap de 65535 (o quadro inteiro é capturado).
  • -C 500 indica um tamanho de ficheiro de 500.000.000 bytes.
  • -w indica a localização do ficheiro de saída. O ficheiro de saída apresentado é gerado automaticamente com o nome de anfitrião do sistema e AAAA-MM-DD em que foi executado. Um arquivo .pcap pode ser analisado no Wireshark.
1. Se o servidor NetWorker for Linux, execute o comando acima no servidor NetWorker. Execute o comando acima no vCenter Server Appliance. Se o servidor NetWorker for o Windows, use o Wireshark para capturar o tráfego enquanto reproduz o problema.

2. Ao reproduzir o problema no NetWorker, ative nsrdispd depurar e executar o nsrvim com depuração.
dbgcommand -n nsrdispd Debug=9

nsrvim -D7 -d vCenter_Hostname > {Path_to_output_file} 2<&1
nve:~ # dbgcommand -n nsrdispd Debug=9
Process ID List : 14600
Processing PID:14600
nve:~ # nsrvim -D7 -d vcsa.amer.lan > /tmp/nsrvim.out 2<&1
nve:~ # ls -l /tmp | grep nsrvim
-rw------- 1 root      root      60025 May 22 10:18 nsrvim.out
nve:~ #
Nota: Se o problema for intermitente, talvez não seja possível reproduzir manualmente o erro. Nesse caso, deixe as capturas de pacotes em execução com a depuração nsrdispd ativada. Certificar-se de que existe espaço adequado disponível na localização do ficheiro de saída e na unidade de instalação do servidor NetWorker.


3. O erro é reportado na daemon.raw do servidor NetWorker.

Linux: /nsr/logs/daemon.raw
Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
NetWorker: NetWorker: How to use nsr_render_log 
NetWorker: NetWorker: How to automatically render daemon.raw to daemon.log in real time 

4. Desative a função nsrdispd depurar e parar a seringa tcpdump:

dbgcommand -n nsrdispd Debug=0

ps -ef | grep tcpdump

kill -9 PID_of_tcpdump
nve:~ # dbgcommand -n nsrdispd Debug=0
Process ID List : 14600
Processing PID:14600
nve:~ # ps -ef | grep tcpdump
root     29439 29267  0 10:01 pts/0    00:00:00 tcpdump -i any -s 0 -C 500 -w /tmp/nve_2024-05-22.pcap
root     29882 29267  0 10:13 pts/0    00:00:00 grep --color=auto tcpdump
nve:~ # kill -9 29439
nve:~ # ps -ef | grep tcpdump
root     29890 29267  0 10:13 pts/0    00:00:00 grep --color=auto tcpdump
[1]+  Killed                  nohup tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap
nve:~ # ps -ef | grep tcpdump
root     29893 29267  0 10:13 pts/0    00:00:00 grep --color=auto tcpdump
nve:~ # ls -l /tmp | grep pcap
-rw------- 1 root      root    5464064 May 22 10:13 nve_2024-05-22.pcap
nve:~ #

Reveja as capturas de pacotes para ver se o servidor vCenter ou um dispositivo de rede está a fechar a ligação.

Información adicional

O NetWorker 19.10 e posterior permite que o administrador de backup altere a nsrvim intervalo. O intervalo padrão é de 15 minutos; no entanto, isso pode ser estendido a qualquer intervalo de até 60 minutos. Esta funcionalidade é detalhada em NVP vProxy: O processo nsrvim do NetWorker é executado a cada 15 minutos, causando uma elevada carga de trabalho no vCenter Server e uma possível indisponibilidade do VPXD.

Productos afectados

NetWorker

Productos

NetWorker Family, NetWorker Series
Propiedades del artículo
Número del artículo: 000206922
Tipo de artículo: Solution
Última modificación: 24 mar 2025
Versión:  12
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