NetWorker: nmc_config falla en un servidor Linux con el mensaje "Unable to Contact Authentication Server on Host Networker_server_hostname and Port 9090"
Resumen: En este artículo, se aborda una advertencia durante la configuración de NMC en un servidor networker como "WARNING: No se puede establecer contacto con el servidor de autenticación en el host Networker_server_hostname y el puerto 9090" cuando el servidor Linux está configurado con hosts proxy. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
- El servidor de NetWorker Management Console (NMC) se instala en un sistema operativo Linux basado en RHEL.
- Cuando se ejecuta el script de configuración de NMC (/opt/lgtonmc/bin/nmc_config), no se puede comunicar con el servidor de autenticación en el puerto 9090 de authc.
[root@networker_server_hostname /]# /opt/lgtonmc/bin/nmc_config
The embedded web server inside the NMC server must run as a non-root user.
Dell recommends that you specify a user that has limited privileges and file access permissions. Default user name used is 'nsrnmc'.
Do you want to create new(cn) certificate or use existing(ue) certificate [cn]?
Create new certificate for https configuration.
Specify the directory to use for the LGTOnmc database[/nsr/nmc/nmcdb]:
Do you want to migrate the NMC server data from a previous LGTOnmc 8.x.x release [n]?
Specify the host name of the Networker Authentication Service host [Networker_server_hostname]:
WARNING: Unable to contact authentication server on host Networker_Server_hostname and port 9090
Do you want to specify a different authentication server host or port [y]?
Causa
El proxy se habilitó en el servidor.
- El siguiente error proviene de /opt/lgtonmc/logs/install.log
129356:gstauthcfg: Unable to get supported versions from authentication server: Received HTTP code 403 from proxy after CONNECT
Server Message : Make sure that server is running
- El siguiente comando muestra los proxies activos:
[root@Networker_server_hostname /]# env |grep -i proxy
http_proxy=http://:8080
https_proxy=http://:8080Resolución
NOTA: El administrador del sistema Linux debe realizar el siguiente procedimiento.
- Tome nota de los proxies que están configurados en el sistema:
[root@Networker_server_hostname /]# env | grep -i proxy
http_proxy=http://:8080
https_proxy=http://:8080
- Si se especifican entradas de proxy en /etc/profile, comente y cierre la sesión.
- Vuelva a iniciar sesión en el servidor de NetWorker y vuelva a ejecutar el script de configuración de NMC: sudo /opt/lgtonmc/bin/nmc_config
Productos afectados
NetWorkerProductos
NetWorker Family, NetWorker SeriesPropiedades del artículo
Número del artículo: 000216702
Tipo de artículo: Solution
Última modificación: 29 nov 2023
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.