NetWorker: nmc_config fails on a Linux server with "Unable to Contact Authentication Server on Host Networker_server_hostname and Port 9090"
Resumen: This article deals with warning while configuring NMC on a networker server as "WARNING: Unable to contact authentication server on host Networker_server_hostname and port 9090" when the Linux server is configured with proxy hosts. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
- The NetWorker Management Console (NMC) server is installed on an RHEL based Linux operating system.
- When running the NMC configuration script (/opt/lgtonmc/bin/nmc_config), it fails to contact the authentication server on authc port 9090.
[root@networker_server_hostname /]# /opt/lgtonmc/bin/nmc_config
The embedded web server inside the NMC server must run as a non-root user.
Dell recommends that you specify a user that has limited privileges and file access permissions. Default user name used is 'nsrnmc'.
Do you want to create new(cn) certificate or use existing(ue) certificate [cn]?
Create new certificate for https configuration.
Specify the directory to use for the LGTOnmc database[/nsr/nmc/nmcdb]:
Do you want to migrate the NMC server data from a previous LGTOnmc 8.x.x release [n]?
Specify the host name of the Networker Authentication Service host [Networker_server_hostname]:
WARNING: Unable to contact authentication server on host Networker_Server_hostname and port 9090
Do you want to specify a different authentication server host or port [y]?
Causa
Proxy was enabled on the server.
- The error below is from /opt/lgtonmc/logs/install.log
129356:gstauthcfg: Unable to get supported versions from authentication server: Received HTTP code 403 from proxy after CONNECT
Server Message : Make sure that server is running
- The following command shows the proxies active:
[root@Networker_server_hostname /]# env |grep -i proxy
http_proxy=http://<proxy-server>:8080
https_proxy=http://<proxy-server>:8080Resolución
NOTE: The below procedure must be performed by the Linux system admin.
- Make note of the proxies which are configured on the system:
[root@Networker_server_hostname /]# env | grep -i proxy
http_proxy=http://<proxy-server>:8080
https_proxy=http://<proxy-server>:8080
- If proxy entries are specified in /etc/profile comment them out and log off.
- Log in to the NetWorker server again and rerun the NMC configuration script: sudo /opt/lgtonmc/bin/nmc_config
Productos afectados
NetWorkerProductos
NetWorker Family, NetWorker SeriesPropiedades del artículo
Número del artículo: 000216702
Tipo de artículo: Solution
Última modificación: 29 nov 2023
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.