Dell Unity: Yhteyden muodostaminen LDAP-palvelimeen ei onnistunut. Tarkista LDAP-määrityksesi uudelleen Directory Services -kohdasta. (Error Code: 0x6000193) [käyttäjän korjattavissa]
Resumen: LDAP: ja LDAPS: yhteyden vahvistus epäonnistuu.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Yhteyden muodostaminen LDAP-palvelimeen ei onnistunut. Tarkista LDAP-määrityksesi uudelleen Directory Services -kohdasta. (Error Code: 0x6000193)
Causa
- Virheelliset LDAP-palvelimen tiedot | LDAP-palvelin ei ole tavoitettavissa
- Virheellinen Bind user DN and Password (Virheellinen Bind user DN and Password)
- Virheellinen LDAP-palvelimen SSL-varmenne, jos käytössä on LDAPS
Resolución
LDAP-palvelimen tiedot
LDAP-palvelimen on oltava ping-kutsuttavissa Unitystä käyttämällä sekä isäntänimeä että IP-osoitetta.
C:\Users\user>nslookup
Server: peeps-dc.peeps.lab - - > > >peeps-dc on isäntänimi || peeps.lab on toimialuenimen
osoite: 5.6.xx.xx-nimi
: peeps-dc.peeps.lab-osoite
: 5.6.xx.xx
C:\Users\user>
Correct Bind user DN and Password
From your Windows host machine, joka liittyy AD:hen, suorita seuraava komento cmd:ssä ja etsi käyttäjätunnus, jotta näet käyttäjän yksilöineen nimen.
C:\Users\Administrator>setspn LdapUser
Registered ServicePrincipalNames for CN=LdapUser,CN=Users,DC=peeps,DC=lab
C:\Users\Administrator>>CN=LdapUser,CN=Users,DC=peeps,DC=lab - > > > Tämä on sidontakäyttäjän
vääräLDAP-palvelimen SSL-varmenne, jos käytössä on LDAPS
Kun SSL-varmenne on ladattu ja yhteys tarkistetaan ja yhteys katkeaa, sen voi tarkistaa ldapsearch-tuloksesta.
Testaa LDAP-yhteys
Ldapsearch-protokollallaldapsearch -x -d 1 -v -H ldap://ldapserver_name_or_IP:389 -b "CN=Users,dc=peeps,dc=lab" -D "CN=Administrator,CN=Users,DC=peeps,DC=lab" -w Password
Haun osa tuloksesta onnistuu:
# filter: (objektiluokan=*)
# pyyntö: KAIKKI
#
res_errno: 0, res_error: <<<<< Bind-haku tai käyttäjähaku onnistui.
ldap_free_request (origid 2, msgid 2),
jos toimialueen ohjauskoneen käytäntö on: Toimialueen ohjauskone: LDAP-palvelimen allekirjoituksen vaatimuksiksi on määritetty Require signing, yhteydet epäonnistuvat, jos niitä ei ole määritetty käyttämään SSL:ää Unispheren LDAPS-vaihtoehdon kanssa.
Jos LDAP-palvelin edellyttää todennusta ja yrität määrittää LDAP:n, et LDAPS:ää lataamatta SSL:ää, tarkista alla oleva ldapsearch-tulos.
Testaa LDAPS-yhteys Ldaps-palvelimella
LDAP-palvelimen on oltava ping-kutsuttavissa Unitystä käyttämällä sekä isäntänimeä että IP-osoitetta.
C:\Users\user>nslookup
Server: peeps-dc.peeps.lab - - > > >peeps-dc on isäntänimi || peeps.lab on toimialuenimen
osoite: 5.6.xx.xx-nimi
: peeps-dc.peeps.lab-osoite
: 5.6.xx.xx
C:\Users\user>
Correct Bind user DN and Password
From your Windows host machine, joka liittyy AD:hen, suorita seuraava komento cmd:ssä ja etsi käyttäjätunnus, jotta näet käyttäjän yksilöineen nimen.
C:\Users\Administrator>setspn LdapUser
Registered ServicePrincipalNames for CN=LdapUser,CN=Users,DC=peeps,DC=lab
C:\Users\Administrator>>CN=LdapUser,CN=Users,DC=peeps,DC=lab - > > > Tämä on sidontakäyttäjän
vääräLDAP-palvelimen SSL-varmenne, jos käytössä on LDAPS
Kun SSL-varmenne on ladattu ja yhteys tarkistetaan ja yhteys katkeaa, sen voi tarkistaa ldapsearch-tuloksesta.
Testaa LDAP-yhteys
Ldapsearch-protokollallaldapsearch -x -d 1 -v -H ldap://ldapserver_name_or_IP:389 -b "CN=Users,dc=peeps,dc=lab" -D "CN=Administrator,CN=Users,DC=peeps,DC=lab" -w Password
Haun osa tuloksesta onnistuu:
# filter: (objektiluokan=*)
# pyyntö: KAIKKI
#
res_errno: 0, res_error: <<<<< Bind-haku tai käyttäjähaku onnistui.
ldap_free_request (origid 2, msgid 2),
jos toimialueen ohjauskoneen käytäntö on: Toimialueen ohjauskone: LDAP-palvelimen allekirjoituksen vaatimuksiksi on määritetty Require signing, yhteydet epäonnistuvat, jos niitä ei ole määritetty käyttämään SSL:ää Unispheren LDAPS-vaihtoehdon kanssa.
Jos LDAP-palvelin edellyttää todennusta ja yrität määrittää LDAP:n, et LDAPS:ää lataamatta SSL:ää, tarkista alla oleva ldapsearch-tulos.
res_errno: 8, res_error: , res_matched:
Testaa LDAPS-yhteys Ldaps-palvelimella
env LDAPTLS_CACERT=/EMC/backend/CEM/LDAPCer/serverCertificate.cer ldapsearch -x -d 1 -v -H ldaps://ldapserver_name_or_IP:636 -b "CN=Users,dc=peeps,dc=lab" -D "CN=Administrator,CN=Users,DC=peeps,DC=lab" -w Password
Jos SSL on virheellinen, ldapsearch-komento näyttää alla olevan tuloksen. TLS-jäljitys: SSL_connect:SSLv3/TLS:n kirjoitusohjelman hello TLS-jäljitys: SSL_connect:SSLv3/TLS:n read server hello TLS-varmenteen vahvistus: syvyys: 1, err: 20, aihe: /DC=lab/DC=peeps/CN=issuer_name, myöntäjä: /CN=issuer_name TLS-varmenteen vahvistus: Virhe, paikallisen myöntäjän varmenteen hakeminen ei onnistu tls_write: want=7, kirjoitettu=7 0000: 15 03 03 00 02 02 30 ...... 0 TLS-jäljitys: SSL3-hälytyksen kirjoitus:vakava:tuntematon CA TLS-jäljitys: SSL_connect:error in error TLS: can't connect: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed (unable to get local issuer certificate). ldap_err2string ldap_sasl_bind (YKSINKERTAINEN): Ei voi ottaa yhteyttä LDAP-palvelimeen (-1) VAROITUS *** Unity-palveluliittymä aktivoitu! VAROITUS*** root@hostname spa:/home/service/user#
Productos afectados
Dell EMC Unity, Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550FProductos
Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F
, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Propiedades del artículo
Número del artículo: 000211909
Tipo de artículo: Solution
Última modificación: 12 dic 2025
Versión: 3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.