Dell Unity: uDoctor Scheduled tasks cause High CPU Utilization (User Correctable)

Resumen: Dell Unity: uDoctor Scheduled tasks cause High CPU Utilization (User Correctable)

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Everyday simultaneously Utilization on the Primary Storage Processor rises up to 90-100% and remains for around 15 minutes.

Causa

The CloudIQ Team has found that a specific Service Data Collection plugin may trigger multiple PSQL commands sometimes.
When this occurs, the PSQL queries cause massive CPU Utilization on the Primary Storage Processor, which is the SP responsible to run uDoctor.

Note: This does not occur when generating and gathering Service Data Collection manually, only affects uDoctor Scheduled tasks, such as the ones from Daily logs generated for CloudIQ.

Resolución

The solution for this issue is already in place and will be in the next Unity OE release version 5.0.3.
For more information regarding Dell EMC Unity OE versions and their release, refer to knowledge article Dell Unity OE Matrix

There is also a workaround that could be applied to mediate the issue until the code is released.
To obtain help implementing this workaround, contact Support and reference knowledge article Dell EMC Unity: uDoctor Scheduled tasks cause High CPU Utilization (User Correctable)

Información adicional

To confirm this is the issue you are experiencing, use the below commands in Unisphere CLI on an SSH terminal of your choice:


On EMCSystemLogFile.log
service@spb:~#  tailf 00_emc_backend_log_shared/EMCSystemLogFile.log | grep -i udoctor
"2020-02-16T13:03:12.155Z" "Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC

"2020-02-17T13:03:12.944Z" "Array_spb@Serial_Number" "Kittyhawk_safe" "9134" "unix/spb/root" "INFO" "1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC


UEMCLI Metrics command (Historical):
service@spb:~# uemcli -no /metrics/value/hist -path sp.*.cpu.summary.utilization show -interval 60 -from "2020-02-16 12:59:00" -to "2020-02-16 13:59:00"
Timestamp           |SP        |summary
                    |          |CPU
                    |          |Util %
--------------------+----------+-------
2020-02-16 13:02:00 |spa       |  13.93
                    |spb       |  66.47
2020-02-16 13:03:00 |spa       |  12.49
                    |spb       |  90.96
2020-02-16 13:04:00 |spa       |  12.94
                    |spb       |  92.63
2020-02-16 13:05:00 |spa       |  11.91
                    |spb       |  93.29
2020-02-16 13:06:00 |spa       |  5.072
                    |spb       |  92.28
2020-02-16 13:07:00 |spa       |  2.497
                    |spb       |  90.06
2020-02-16 13:08:00 |spa       |  2.452
                    |spb       |  92.38
2020-02-16 13:09:00 |spa       |  2.527
                    |spb       |  95.68
2020-02-16 13:10:00 |spa       |  2.441
                    |spb       |  98.36
2020-02-16 13:11:00 |spa       |  2.845
                    |spb       |  97.170
2020-02-16 13:12:00 |spa       |  2.466
                    |spb       |  97.096
2020-02-16 13:13:00 |spa       |  2.479
                    |spb       |  97.732
2020-02-16 13:14:00 |spa       |  2.469
                    |spb       |  98.023
2020-02-16 13:15:00 |spa       |  2.362
                    |spb       |  96.391
2020-02-16 13:16:00 |spa       |  2.697
                    |spb       |  65.053


UEMCLI Metrics command (Real Time):
service@spb:~# uemcli -no /metrics/value/rt -path sp.*.cpu.summary.utilization show -interval 10
Timestamp           |SP        |summary
                    |          |CPU
                    |          |Util %
--------------------+----------+-------
2020-02-17 13:03:20 |spa       |  0.929
                    |spb       |  90.810
2020-02-17 13:03:30 |spa       |  1.928
                    |spb       |  90.980
2020-02-17 13:03:40 |spa       |  2.417
                    |spb       |  90.537
2020-02-17 13:03:50 |spa       |  1.912
                    |spb       |  91.601
2020-02-17 13:04:00 |spa       |  2.124
                    |spb       |  93.625
2020-02-17 13:04:10 |spa       |  3.828
                    |spb       |  92.191

 

Productos afectados

Dell EMC Unity Family

Productos

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Propiedades del artículo
Número del artículo: 000058581
Tipo de artículo: Solution
Última modificación: 18 abr. 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.