NetWorker: Backup del client Windows pseudo_saveset - Errori VSS
Resumen: Il client NetWorker ha esito negativo per pseudo_saveset con problemi nel servizio VSS (Volume Shadow Copy Service).
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Síntomas
- Il backup viene eseguito per un sistema Windows utilizzando il software client NetWorker.
- Il backup non riesce su pseudo_saveset.
- I registri di backup segnalano errori di Microsoft Volume Shadow Copy Service (VSS). Ad esempio:
181407:save: Step (1 of 5) for PID-8600: Save has been started on the client ''.
174412:save: Step (2 of 5) for PID-8600: Running the backup on the client '' for the save set 'pseudo_saveset'.
174424:save: Step (3 of 5) for PID-8600: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot: Unable to create the VSS snapshot.
197048:save: Unable to save the SYSTEM STATE save sets and create the snapshot: Unable to create the VSS snapshot.
NOTA: Questo è un esempio di errore VSS che può essere osservato. Anche se non si tratta dell'errore VSS esatto osservato, è comunque possibile seguire questo articolo.
- Impossibile creare la snapshot VSS.
Causa
VSS è una tecnologia Microsoft utilizzata dai backup di NetWorker. I problemi di VSS sono in genere sul client relativi al sistema operativo o a una nuova patch installata che ha interessato VSS.
Resolución
Sul client:
I seguenti comandi vssadmin possono fornire ulteriori informazioni sullo stato del writer vssadmin o se eventuali snapshot VSS risiedono ancora nel sistema.
- Aprire il prompt dei comandi come amministratore.
- Arrestare il client NetWorker:
net stop nsrexecd /y
- Terminare eventuali servizi NetWorker che non si sono arrestati:
taskkil /F /IM nsr*
- Terminare tutti i processi di backup di NetWorker che non si sono arrestati:
taskkill /F /IM save*
- Rinominare C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
- Rimuovere C:\Program Files\EMC NetWorker\nsr\tmp (anche qualsiasi directory /tmp rinominata).
- Aprire SERVICES (o services.msc).
- Cercare il servizio VOLUME SHADOW COPY STOP e quindi START per questo servizio
- Iniziare Servizi client NetWorker:
net start nsrexecd
- Se il problema persiste, testare un file o una directory di piccole dimensioni per eseguire il backup ed escludere VSS:
- Sul client, aprire un prompt dei comandi amministratore.
- Eseguire il comando seguente per testare un piccolo backup di una directory o di un file di propria scelta:
save -vv -D5 -s -b -o VSS:*=off
- Se il backup ha esito positivo, disabilitare VSS nella configurazione client.
NOTA: La disabilitazione di VSS nei backup deve essere eseguita solo come soluzione alternativa. La root cause dei problemi di VSS deve essere determinata e risolta in modo da poter eseguire i backup di Windows con VSS abilitato.
- Per disabilitare VSS per un particolare client, aprire le proprietà del client in NetWorker Management Console (NMC).
- Nella scheda APPS&MODULES > inserire il comando di backup :
save -o VSS:*=offPer determinare la root cause di qualsiasi problema di VSS, si consiglia di contattare il team di amministrazione Microsoft o il supporto Microsoft per esaminare la causa degli errori di VSS.
I seguenti comandi vssadmin possono fornire ulteriori informazioni sullo stato del writer vssadmin o se eventuali snapshot VSS risiedono ancora nel sistema.
vssadmin list writers vssadmin list shadows
Productos afectados
NetWorker FamilyPropiedades del artículo
Número del artículo: 000217007
Tipo de artículo: Solution
Última modificación: 29 nov. 2023
Versión: 10
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