PPDM: VM backup is completing with exception: Unable to create quiesced snapshot. An error occurred while quiescing the virtual machine

Resumen: PowerProtect VADP-based VM backups are completed successfully but certain Windows 2012 and/or 2016 VMs show exceptions when VMware tries to take a Quiesced snapshot.

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Síntomas

The PowerProtect Data Manager (PPDM) is used to protect the vSphere environment with the VM Direct Engine solution.
The virtual machine (VM) backups are completing successfully, but certain Windows VMs complete with exceptions.
Warnings occurred during snapshot creation. Non-quiesced snapshot was used, quiesced snapshot was unsuccessful. Unable to create quiesced snapshot. An error occurred while quiescing the virtual machine.
The affected VM vmware.log file, found in the VMware datastore folder, shows an error when performing the snapshot:
YYYY-MM-DD HH:MM:SS In(05) vmx - Msg_Post: Warning
YYYY-MM-DD HH:MM:SS In(05) vmx - [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing.
YYYY-MM-DD HH:MM:SS In(05)+ vmx - The error code was: 5
YYYY-MM-DD HH:MM:SS In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8454 (0x80042306)

Causa

This is a known VMware issue when the VM has a GPT disk without an MSR (Microsoft Reserved) partition.

See the following VMware Knowledge Base article. 
https://kb.vmware.com/s/article/71130 - Unable to take quiesced snapshot of Windows Server virtual machine with gpt disks without MSR partition (71130)

Resolución

The resolution provided in the VMware article is to modify the VM disk configuration.

Workaround:

The "Enable guest file system quiescing" option can be removed from the VMware Protection Policy to create a non-quiesced snapshot for the backup.

Productos afectados

PowerProtect Data Manager Software
Propiedades del artículo
Número del artículo: 000211244
Tipo de artículo: Solution
Última modificación: 06 jun. 2023
Versión:  2
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