Code d’événement Openshift : 1030NODE0005

Résumé: Le système de fichiers dispose de moins de 3 % d’espace restant.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

La saturation du système de fichiers d’un nœud peut avoir un impact négatif généralisé. Ce problème peut entraîner la dégradation des performances de l’une ou l’ensemble des applications planifiées sur ce nœud et les rendre totalement inutilisables.

Selon le nœud et le système de fichiers concernés, ce problème peut constituer une menace critique pour la stabilité du cluster.

Cause

L’alerte NodeFilesystemAlmostOutOfSpace est similaire à l’alerte NodeFilesystemSpaceFillingUp, mais plutôt que d’être basée sur une prédiction qu’un système de fichiers sera saturé dans un certain laps de temps, elle utilise des seuils statiques simples.

Cette alerte se déclenche à un niveau d’avertissement lorsqu’il reste 5 % d’espace dans le système de fichiers et à un niveau critique lorsqu’il reste 3 % d’espace.

Résolution

Diagnostic :
étudiez les tendances récentes d’utilisation du système de fichiers sur un tableau de bord. Parfois, un modèle périodique d’écriture et de nettoyage dans le système de fichiers peut entraîner le déclenchement d’une fausse alerte par l’algorithme de prédiction linéaire.

Utilisez les outils et utilitaires du système d’exploitation Linux pour identifier les répertoires qui utilisent le plus d’espace dans le système de fichiers. S’agit-il d’une condition irrégulière, comme un processus qui ne parvient pas à se nettoyer derrière lui-même et qui utilise une grande quantité d’espace ? Ou le problème semble-t-il être lié à la croissance organique ?

Pour vous aider dans votre diagnostic, observez la métrique suivante dans PromQL (exécutez la requête sur la console Web OCP : Observez → Metrics → Run queries) :

node_filesystem_free_bytes

Ensuite, cochez la case mountpoint Libellé de l’alerte.

Solution d'atténuation :

Si la capacité mountpoint L’étiquette est //sysroot ou /var, supprimez les images inutilisées pour résoudre le problème :

1.Déboguez le nœud en accédant au système de fichiers du nœud :
$ NODE_NAME=<libellé de l’instance à partir d’alert$>
oc -n default debug node/$NODE_NAME
$ chroot /host


2.Supprimer les images pendantes :
$ podman images -q -f dangling=true | xargs --no-run-if-empty podman rmi

3.Supprimer les images inutilisées :
$ podman images | grep -v -e registry.redhat.io -e « quay.io/openshift » -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null

4.Exit debug :
$ exit
$ exit

Support :
si toutes les étapes ci-dessus ne permettent pas de résoudre le problème, contactez le support technique Dell EMC pour une procédure d’enquête plus approfondie.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217410
Type d’article: Solution
Dernière modification: 19 févr. 2026
Version:  3
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