Openshift-Ereigniscode: 1038NODE0007

Résumé: Es wird prognostiziert, dass der Speicherplatz im Dateisystem innerhalb der nächsten 4 Stunden knapp wird.

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Symptômes

Wenn der Speicherplatz in einem Dateisystem knapp wird, verschlechtert sich die Systemleistung in der Regel allmählich.

Wenn ein Dateisystem voll wird und kein Speicherplatz mehr vorhanden ist, können Prozesse, die in das Dateisystem schreiben müssen, dies nicht mehr tun, was zu Datenverlust und Systeminstabilität führen kann.

Cause

Bei der NodeFilesystemSpaceFillingUp Warnmeldung wird ausgelöst, wenn zwei Bedingungen erfüllt sind:

  • Die aktuelle Dateisystemnutzung überschreitet einen bestimmten Schwellenwert.
  • Ein Extrapolationsalgorithmus sagt voraus, dass innerhalb einer bestimmten Zeit kein Speicherplatz mehr im Dateisystem vorhanden sein wird. Wenn der Zeitraum weniger als 24 Stunden beträgt, ist dies ein Warning Warnung. Wenn die Zeit weniger als 4 Stunden beträgt, ist dies ein Critical Warnung.

Résolution

Diagnose

  • Untersuchen Sie die neuesten Trends der Dateisystemnutzung auf einem Dashboard. Manchmal kann ein regelmäßiges Muster des Schreibens und Bereinigens im Dateisystem dazu führen, dass der lineare Vorhersagealgorithmus eine falsche Warnmeldung auslöst.

  • Verwenden Sie die Tools und Dienstprogramme des Linux-Betriebssystems, um zu untersuchen, welche Verzeichnisse den meisten Speicherplatz im Dateisystem belegen. Handelt es sich bei dem Problem um einen unregelmäßigen Zustand, z. B. wenn ein Prozess nicht hinter sich selbst bereinigt werden kann und viel Speicherplatz verwendet? Oder scheint das Problem mit organischem Wachstum zusammenzuhängen?

Um Ihre Diagnose zu unterstützen, beobachten Sie die folgende Metrik in PromQL (Führen Sie die Abfrage auf der OCP-Webkonsole aus): Beachten Sie → Metriken → Ausführen von Abfragen):

node_filesystem_free_bytes

Überprüfen Sie dann die mountpoint Bezeichnung für die Warnmeldung.

Minderung

Wenn die mountpoint Etikett ist //sysroot oder /varentfernen, entfernen Sie nicht verwendete Bilder, um das Problem zu beheben:

  1. Debuggen Sie den Node, indem Sie auf das Node-Dateisystem zugreifen:

    $ NODE_NAME<=Instanzbezeichnung der Warnmeldung>
    $ oc -n Standard-Debug-Node/$NODE_NAME
    $ chroot /Host

     

  2. Entfernen Sie ausstehende Bilder:

    $ podman images -q -f dangling=true | xargs --no-run-if-empty podman rmi

     

  3. Entfernen Sie nicht verwendete Images:

    $ podman Bilder | grep -v -e registry.redhat.io -e "quay.io/openshift" -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null
     
  4. Beenden Sie das Debuggen:

    $ Exit
    $ Exit

     

Support

Wenn das Problem durch die oben genannten Schritte nicht behoben werden kann, wenden Sie sich für weitere Untersuchungen an den technischen Support von Dell EMC.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217422
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version:  3
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