Openshift-hændelseskode: 1038NODE0007

Résumé: Filsystemet forventes at løbe tør for plads inden for de næste 4 timer.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Når et filsystem begynder at løbe tør for plads, forringes systemets ydeevne normalt gradvist.

Hvis et filsystem fyldes op og løber tør for plads, kan processer, der skal skrive til filsystemet, ikke længere gøre det, hvilket kan resultere i tabte data og ustabilitet i systemet.

Cause

Ikonet NodeFilesystemSpaceFillingUp Advarsel udløses, når to betingelser er opfyldt:

  • Det aktuelle filsystemforbrug overstiger en vis tærskel.
  • En ekstrapoleringsalgoritme forudsiger, at filsystemet løber tør for plads inden for en vis tid. Hvis tidsperioden er mindre end 24 timer, er dette en Warning Alert. Hvis tiden er mindre end 4 timer, er dette en Critical Alert.

Résolution

Diagnose

  • Undersøg de seneste tendenser for filsystembrug på et dashboard. Nogle gange kan et periodisk mønster med skrivning og oprydning i filsystemet få den lineære forudsigelsesalgoritme til at udløse en falsk alarm.

  • Brug Linux-operativsystemets værktøjer og hjælpeprogrammer til at undersøge, hvilke mapper der bruger mest plads i filsystemet. Er problemet en uregelmæssig tilstand, såsom en proces, der ikke rydder op bag sig selv og bruger en stor mængde plads? Eller synes spørgsmålet at være relateret til organisk vækst?

For at hjælpe med din diagnose skal du se følgende måling i PromQL(udfør forespørgslen på OCP-webkonsollen: Hold øje med → metrikværdier → kørselsforespørgsler):

node_filesystem_free_bytes

Kontroller derefter mountpoint etiket til advarslen.

Afbødning

Hvis ikonet mountpoint Etiketten er //sysroot eller /var, skal du fjerne ubrugte billeder for at løse problemet:

  1. Foretag fejlfinding af noden ved at få adgang til nodefilsystemet:

    $ NODE_NAME=<Etiket til forekomst fra besked>
    $ oc -n standard fejlretningsnode/$NODE_NAME
    $ chroot / vært

     

  2. Fjern dinglende billeder:

    $ podman billeder -q -f dinglende = sandt | xargs --no-run-if-empty podman rmi

     

  3. Fjern ubrugte billeder:

    $ podman billeder | grep -v -e registry.redhat.io -e "quay.io/openshift" -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null
     
  4. Afslut fejlfinding:

    $ exit
    $ exit

     

Support

Hvis alle ovenstående trin ikke kan løse problemet, skal du kontakte Dell EMC s tekniske support for yderligere undersøgelse.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217422
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.