NetWorker : Échec du client Windows avec l’erreur « Le processus ne peut pas accéder au fichier car il est utilisé par un autre processus (erreur Win32 0x20)) »

Résumé: Échec du client Windows avec l’erreur « Le processus ne peut pas accéder au fichier car il est utilisé par un autre processus (erreur Win32 0x20)) »

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Le client Windows ne parvient pas à sauvegarder certains savesets et l’erreur suivante s’affiche : « Le processus ne peut pas accéder au fichier car il est utilisé par un autre processus (Win32 error 0x20)"

Cause

Il ne s’agit pas d’une erreur NetWorker, cela est indiqué par le code d’erreur du système d’exploitation Windows : (Win32 error 0x20)

0x00000020

ERROR_SHARING_VIOLATION

Le processus ne peut pas accéder au fichier, car il est utilisé par un autre processus.


Consultez le document Microsoft suivant : Codes d’erreur Win32 Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.

Résolution

Cela ne doit pas se produire sur les clients sur lesquels le service VSS (Volume Shadow Copy Service) est activé. Pour vérifier si VSS est activé, ouvrez les propriétés du client à partir de NetWorker Management Console (NMC). Sous Protection-Clients, dans les propriétés du client, onglet Applications et modules, assurez-vous> que le champ « Opérations de sauvegarde » ne contient pas  VSS:*=OFF
Enregistrer l’opération pour désactiver VSS 
Si cette option est définie, supprimez-la.

Informations supplémentaires

Sur la plupart des clients de système de fichiers Windows standard, VSS ne doit pas être désactivé. Cette opération ne doit être effectuée qu’à des fins de dépannage afin d’identifier Windows VSS comme une autre cause de défaillance. Les défaillances VSS persistantes nécessitent l’engagement du support Microsoft pour trouver la cause première et la solution.

Si l’activation de VSS ne résout pas le problème, ou si vous ne souhaitez pas l’activer, deux autres options s’offrent à vous :

  1. Essayez de planifier la sauvegarde de ce client pendant une période où l’activité d’accès est réduite.
  2. Utilisez les directives NetWorker pour ignorer ces fichiers, afin que la sauvegarde n’indique pas d’échec. Toutefois, cela signifie que les données ne sont pas sauvegardées. Cette résolution dépend de l’importance des répertoires/fichiers qui échouent avec ce message. En général, cette erreur se produit sur les fichiers .log et .dat. Le NetWorker Command Reference Guide fournit des informations sur les directives. Prise en charge de NetWorker | Manuels et documents 


Pour plus d’informations sur VSS et ses utilisations, consultez les sections suivantes : Service de cliché instantané des volumes Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.

NetWorker : Dépannage des échecs de sauvegarde dus à des problèmes VSS

Produits concernés

NetWorker

Produits

NetWorker
Propriétés de l’article
Numéro d’article: 000031490
Type d’article: Solution
Dernière modification: 24 oct. 2025
Version:  6
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