BIOSアップデートまたはマザーボードの交換後にUbuntuが起動しない
Résumé: この記事では、Ubuntu Linuxを実行しているXPSおよびPrecisionコンピューターに影響するNo Bootの問題について説明します。これは、マザーボードを交換した後、またはBIOSをデフォルト設定にアップデート/復元した後に発生します。
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
どうしたんですか
Ubuntu Linux搭載のDell XPSまたはPrecision PCは、次のいずれかのイベント後に起動しません。
- BIOSをアップデートした
- BIOSを元の設定にリセットした場合
- 技術者がマザーボードを交換しました
コンピュータの電源を入れると、「起動デバイスが見つかりませんでした」などのエラーメッセージが表示されます。
Cause
なぜこのようなことが起こるのか
これらの変更のいずれかが発生すると、コンピューターのBIOSはSATA動作と呼ばれる設定を自動的に[RAID On]に切り替えます。SATAは、ハード ドライブ接続を管理するシステムと考えてください。
ここに問題があります: Ubuntu Linuxでは、この設定を[RAID On]ではなく、[AHCI](Advanced Host Controller Interface)にする必要があります。設定が[RAID On]に変更されると、Ubuntuはハード ドライブを見つけられなくなり、コンピューターが起動しなくなります。
幸いなことに、この設定を簡単に元に戻すことができ、コンピューターは再び正常に動作します。
Résolution
修正方法
SATA設定をAHCIに戻し、Ubuntuが正常に起動できるようにするお手伝いをします。これには約5〜10分かかります。
手順1:SATA設定をAHCIに変更します
- コンピュータの電源を入れ、すぐにBIOSセットアップ画面が表示されるまで F2 キーを繰り返し押します。
- 矢印キーを使用して 、[System Configuration]に移動します。
- [SATA Operation]を選択します。
- 設定を [RAID On ]から [AHCI]に変更します。
- この変更を保存するには 、[Apply ]を押します。
これにより、Ubuntuがハードドライブを再び検出できるようになります。
手順2:起動オプションを再作成します
Ubuntuは、特別なファイルを使用して起動します。BIOSを変更した後、このファイルの場所をコンピューターに通知する必要があります。
- BIOSで、矢印キーを使用して [General]に移動します。
- [Boot Sequence]を選択します。
- [ Add Boot Option]を選択します。
- [ファイル名] の横にある右側のボタンを選択して、ファイル ブラウザー ウィンドウを開きます。
- [ディレクトリー]セクションで、[EFI]をダブルクリックします。
- [ Ubuntu]をダブルクリックします。
- [Files]セクションで、[shimx64.efi]を選択します。

- [OK]を選択します。
- [Boot Option Name]フィールドに「UBUNTU」と入力します(すべて大文字で読みやすくします)。

- リストから他の起動オプションをすべて削除して、Ubuntuのみが選択されていることを確認します。
- [適用] を選択し、[OK] を選択して変更を保存します。
- [Exit]を選択します。
コンピューターが再起動し、Ubuntuが正常に起動するはずです。
Produits concernés
XPS, XPS, Fixed Workstations, Mobile Workstations, Dell Canvas 27, Red Hat Enterprise Linux Version 8, Ubuntu Server LTS, XPS 13 9350 (End of Life)Propriétés de l’article
Numéro d’article: 000177068
Type d’article: Solution
Dernière modification: 11 déc. 2025
Version: 13
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.