Avamar: Slow backup due to third-party software modifying metadata for unchanged files
Résumé: Avamar backup runs slow due to third-party software modifying metadata for unchanged files.
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Symptômes
Avamar backups take a long time to complete and may time out.
Avamar backups take a long time and are found to be processing unusually large proportion of modified files.
For example:
For example:
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new)
avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour)
Cause
The Avamar client process, avtar, relies on the ctime of a file to determine if that file changed.
If third-party software alters the ctime of a file in the dataset, avtar considers the file as changed.
Avtar processes the entire file (chunk, compress, and hash).
This can take considerable time if many files have had their ctime modified.
If third-party software alters the ctime of a file in the dataset, avtar considers the file as changed.
Avtar processes the entire file (chunk, compress, and hash).
This can take considerable time if many files have had their ctime modified.
Résolution
Compare the latest backup log with earlier backup logs to understand if the behavior is normal.
If the behavior differs greatly, consider that some other process, or program may be causing the data to change.
Investigate which whether any third-party applications are updating file metadata either be due to malfunction or design.
Ensure that the latest patches are applied for the third-party product.
Discuss with the vendor's support team whether it is possible to prevent the behavior from occurring.
Avamar Support has observed this behavior with the following third-party products.
Sophos:
If the behavior differs greatly, consider that some other process, or program may be causing the data to change.
Investigate which whether any third-party applications are updating file metadata either be due to malfunction or design.
Ensure that the latest patches are applied for the third-party product.
Discuss with the vendor's support team whether it is possible to prevent the behavior from occurring.
Avamar Support has observed this behavior with the following third-party products.
Sophos:
- This is documented in Poor backup performance for Avamar client running Sophos anti-virus.
Trend Micro:
- See hotfix 1383 in these release notes.
Symantec:
- Links to the Symantec document have since become unavailable
Netbackup:
Informations supplémentaires
Practical troubleshooting:
The Process Monitor tool may be useful to help identify which process is causing large numbers of files to be modified or created.
The Process Monitor tool may be useful to help identify which process is causing large numbers of files to be modified or created.
Produits concernés
AvamarProduits
Avamar, Avamar ClientPropriétés de l’article
Numéro d’article: 000041049
Type d’article: Solution
Dernière modification: 06 févr. 2025
Version: 5
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