ЕКС: Вимкнення функції блокування об'єктів на ECS для IBM Content Manager
Résumé: IBM Content Manager не запускається на ECS 3.6.2 після перезапуску служб, коли в сегменті вимкнено блокування об'єкта.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
На програму вплинула помилка 501. Нижче наведено дані з dataheadsvc.log на ECS:
dataheadsvc.log.20211016-013228.gz:2021-10-16T01:04:12,908 [qtp911357121-41701] INFO RequestLog.java (line 83) 1x.xx.1xx.xx GET //test-bucket/?object-lock= HTTP/1.1 501 3 – 160
Cause
Код ECS версії 3.6.2 Запроваджено функцію блокування об'єктів, але є дві передумови для ввімкнення блокування об'єктів для сегментів ECS:
- Блокування об'єктів не працює з сегментом ADO з увімкненим ADO. Цю проблему розглянуто у 3.7.1.
- Блокування об'єктів не працює з застарілими користувачами. (Користувачі, які не є користувачами IAM)
Résolution
Відомо, що це обмеження впливає на такі програми, як IBM Content Manager, який перевіряє наявність "?object-lock" після запуску. До версії 3.6.2 ECS було розроблено для ігнорування блокування об'єктів. Після 3.6.2 повертаються коди повернення 403 або 404.
Починаючи з версії 3.6.2.1 і пізніших версій, блокування об'єктів можна вимкнути, якщо потрібно, за допомогою латки. У версії 3.7 блокування об'єктів можна вимкнути глобально або ввімкнути чи вимкнути для певних сегментів.
Зв'яжіться зі службою підтримки Dell Technologies ECS, щоб вимкнути блокування об'єкта, якщо це необхідно.
Propriétés de l’article
Numéro d’article: 000192958
Type d’article: Solution
Dernière modification: 06 avr. 2023
Version: 6
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.