ECS : Dial Home - EKMServerConnectionStatus - Symptom Code : 1369 et 1370

Résumé: Il s’agit d’un appel à distance qui a été introduit pour détecter l’alerte EKMServerConnectionStatus.

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Symptômes

ECS a composé un appel à distance avec l’alerte suivante :
Code symptôme Gravité
1369 AVERTISSEMENT
1370 ERREUR
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
            <ConnectNum>xx.xxx.xxx.xx</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1370</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>EKM Server Connection Status</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
                    <LastTime>2022-01-29T07:32:09.718Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected.  [Ref_ID : EKMServerConnectionStatus]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

Le serveur EKM (Extensible Key Management) ne répond pas. Assurez-vous que le serveur est connecté.

Résolution

Vérifier l’état

Commande : 
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
Exemple :
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>KMServerConnectionStatus</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>EKMServerConnectionStatus</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
Recherchez CurrentState comme ci-dessus. S’il est défini sur OK, l’erreur peut être ignorée. Si le problème persiste (avertissement ou erreur), suivez les étapes de dépannage ci-dessous.

Dépannage

Recherchez le serveur indiqué dans le message d’alerte reçu et essayez de lui envoyer une commande ping :
Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
Vérifiez resourcesvc.log les messages relatifs au problème EKM server :
Command :
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
Exemple :
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
Les erreurs indiquent un problème réseau possible dans l’environnement. La communication entre ECS et le serveur EKM peut être bloquée, ou le serveur EKM lui-même peut être indisponible. Vérifiez qu’ECS peut envoyer une commande ping au serveur EKM et invitez l’utilisateur à vérifier que le serveur EKM fonctionne.

Si vous ne parvenez pas à résoudre le problème, ouvrez une demande de service auprès du support ECS pour obtenir de l’aide avec les informations collectées ci-dessus.

Produits concernés

ECS, ECS Appliance, ECS Software, Elastic Cloud Storage
Propriétés de l’article
Numéro d’article: 000038620
Type d’article: Solution
Dernière modification: 17 Dec 2025
Version:  7
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