Dépannage des problèmes matériels liés à la bibliothèque de bandes dans NetWorker

Résumé: Cet article est destiné à aider le support et les administrateurs NetWorker à vérifier les problèmes au niveau de la bibliothèque ou du transport, afin d’exclure les problèmes au niveau de l’hôte et de l’application. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

    • Impossible d’utiliser la bibliothèque de manière fiable pour la sauvegarde NetWorker
    • Réception d’erreurs ou de messages ASC/ASCQ/SCSI SENSE dans les logs du système ou de l’application
    • Impossible de détecter la présence d’une bibliothèque à partir de l’hôte de contrôle du robot prévu
    • Incapacité de la bibliothèque à passer à l’état Prêt dans NetWorker
    • Erreurs sporadiques ou cohérentes lors de l’exécution d’opérations de bibliothèque spécifiques ou aléatoires

    Cause

    Si la bibliothèque fonctionnait auparavant et rencontre soudainement un problème, envisagez les modifications possibles qui peuvent entraver les opérations :

    • Modification du firmware, du pilote ou de la configuration du robot, du commutateur ou de l’adaptateur
    • Ajout, remplacement ou retrait de matériel de bande, de cartouches de bande ou d’autres composants de bibliothèque
    • Modification de la version du logiciel NetWorker, correctifs du système d’exploitation
    • Tout événement matériel, tel qu’une perte d’alimentation ou le redémarrage d’un composant du chemin d’accès des données.
    • Toutes les activités impliquant l’ouverture de la porte de la bibliothèque

    Résolution

    Pour identifier un problème matériel dans une bibliothèque de bandes, les opérations doivent être testées à leurs niveaux les plus décentralisés. Afin d’isoler le problème, le transport basé sur SCSI est supprimé du chemin d’accès des données pour tester les fonctions pures de la bibliothèque.

    Gardez à l’esprit que plusieurs composants de la bibliothèque peuvent sembler fonctionnels. La défaillance d’un composant masqué peut empêcher la bibliothèque de fonctionner correctement pour les applications hôtes. Par exemple, un robot peut déplacer correctement les volumes, mais sa logique interne peut mal identifier les numéros de série des disques ou perdre la trace des emplacements des éléments. Une commande peut réussir via l’interface Web, mais la bibliothèque peut ne pas parvenir à se connecter au commutateur SAN. Cela peut indiquer un problème de GBIC ou de fond de panier côté cible.

    Exécutez les tests de base suivants pour confirmer quelles fonctions fonctionnent sur chaque interface. Utilisez ces techniques pour tenter une récupération avant de faire appel au fournisseur de bibliothèque.

    AVERTISSEMENT : Ces suggestions ne sont fournies qu’à titre indicatif et l’administrateur de la bibliothèque est responsable de l’entretien de leur stockage. En cas de doute quant à la sécurité d’une opération, contactez le vendeur de la bibliothèque avant de poursuivre. En fin de compte, les fournisseurs ont accès à des outils et à des informations que le support NetWorker n’a peut-être pas.

    Matériel de bibliothèque : écran LCD

    Commencez le dépannage aussi localement que possible auprès du robot - pour la plupart des administrateurs de bibliothèque, il s’agit du panneau d’affichage à l’avant de l’unité de bibliothèque. À partir de ce stade, il est conseillé d’exclure les problèmes spécifiques au transport SCSI, à Ethernet ou à l’interface utilisateur Web.

    • Recherchez les erreurs : en général, un défaut évident dans le stockage s’affiche sous la forme d’un code d’erreur dans la fenêtre principale ou dans un sous-menu « Alertes » ou « Erreurs ». Tout problème rencontré ici doit être signalé immédiatement au fournisseur (le non-respect de cette consigne peut exacerber les dommages).
    • Test des opérations de base dans l’interface utilisateur (identiques à celles testées sur l’écran LCD)
      • Déplacez une cartouche de bande d’un logement à un autre, d’un lecteur à un autre, d’un lecteur à un autre et d’un logement à l’autre.
      • S’il existe un emplacement ou un magasin d’importation et d’exportation, testez les mêmes fonctions avec eux, en utilisant toutes les combinaisons de source et de destination, comme indiqué ci-dessus.
      • Testez l’exportation et l’importation physique des cartouches de bande depuis et vers la bibliothèque.
      • Testez les fonctions d’initialisation, d’inventaire et de réinitialisation de la bibliothèque, le cas échéant.
      • Si une cartouche de bande ne peut pas être retirée d’une main, d’un lecteur ou d’un logement robotisé, vous devez la supprimer manuellement de la bibliothèque avant de continuer.
    • Confirmer la présentation des données :
      • Assurez-vous que les emplacements des cartouches de bande, les codes-barres et l’état des lecteurs sont corrects.
      • Vérifiez quelles fonctionnalités de la bibliothèque, le cas échéant, sont activées et confirmez les effets.
    • Les bibliothèques virtuelles n’ont pas d’écran LCD, mais leur état peut être vérifié au niveau le plus primitif à la ligne de commande du périphérique de stockage qui les virtualise ; À l’instar des bibliothèques physiques, l’assistance des fournisseurs, avec leurs outils et leurs connaissances spécialisées, peut être nécessaire.

    Library Intelligence : interface utilisateur Web

    Le niveau de test suivant qui est couramment disponible est l’interface Web qui sert d’interface utilisateur de la bibliothèque. Cette interface est commune aux bibliothèques de bandes physiques et virtuelles, et vise à fournir un accès complet à la bibliothèque et à ses fonctions.

    Cette méthode de test contourne le chemin de données SCSI normal, y compris l’adaptateur de bus hôte (HBA), les commutateurs et les ports cibles. Il envoie des commandes SCSI directement du serveur Web embarqué au robot. En tant que tel, il se peut qu’il ne s’agisse pas d’une représentation fidèle des problèmes réels rencontrés dans l’utilisation standard.

    • Comme indiqué ci-dessus, recherchez dans l’interface utilisateur des alertes, des files d’attente d’erreurs ou des indications au sein de l’interface. Là encore, les problèmes signalés par la bibliothèque doivent être immédiatement signalés au fournisseur.
    • Testez les opérations de base dans l’interface utilisateur telles qu’elles ont été effectuées sur l’écran LCD, si possible.
    • Confirmez les données de l’interface utilisateur telles qu’elles ont été effectuées sur l’écran LCD, y compris la connectivité de l’hôte, les emplacements des codes-barres, les numéros de série des disques et toutes les autres données pertinentes

    Service de bibliothèque - Fournisseur :

    Si la bibliothèque indique qu’il n’y a pas de pannes, mais que des problèmes matériels se produisent dans les couches de commutateur, de transport ou d’hôte, contactez le fournisseur. Ils peuvent procéder au dépannage à l’aide d’outils et de connaissances spécialisés. Avant d’effectuer cette opération :

    • Éteignez complètement la bibliothèque et laissez-la hors tension (et idéalement, débranchée) pendant 5 minutes. Les appareils de grande taille, tels que les bibliothèques de bandes, ont besoin de temps pour que les condensateurs se déchargent et peuvent potentiellement éliminer les conditions de dysfonctionnement.
    • Organisez-vous pour mettre à niveau le micrologiciel du robot et des entraînements (souvent, cela nécessite de toute façon l’aide du fournisseur). Pour les problèmes matériels, il est préférable d’être sur le code à jour.
    • Assurez-vous que tous les câbles ou disques défectueux ont été retirés de la bibliothèque. Il n’est pas rare qu’un composant défectueux en affecte d’autres. Remplacez tous les composants suspects pour effectuer un test, si possible, afin d’isoler davantage le problème.

    Informations supplémentaires

    Assurez-vous que vous comprenez que les problèmes robotiques qui se révèlent être hors du champ d’application de NetWorker (c’est-à-dire qui ne sont pas accessibles à l’aide des méthodes standard du système d’exploitation) ne relèvent pas du support NetWorker.
    Networker: Dépannage des problèmes liés aux bibliothèques de bandes dans NetWorker

    Le support peut fournir des conseils à l’aide des critères ci-dessus, mais nous ne disposons pas de ressources de fournisseurs de systèmes d’exploitation, d’adaptateurs HBA ou de robotique. Cette limitation peut entraîner un dépannage prolongé et infructueux.

    Produits concernés

    NetWorker

    Produits

    NetWorker, NetWorker Series
    Propriétés de l’article
    Numéro d’article: 000036104
    Type d’article: Solution
    Dernière modification: 23 Jan 2026
    Version:  5
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