SRM 4.5 : Le service Web Service Gateway (WSG) ne s’exécute pas après la mise à niveau vers la version 4.5 ou 4.5.0.1 : Exception « Insufficient configured threads »

Résumé: Le service Web Service Gateway (WSG) ne parvient pas à démarrer sur les machines virtuelles SRM 4.5 et 4.5.0.1 ou sur les hôtes dotés de plus de 16 cœurs de processeur. Cela concerne également les mises à niveau de SRM vers les versions 4.5 et 4.5.0.1. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Deux symptômes potentiels sont associés au problème décrit dans cet article de la base de connaissances :
  • Les mises à niveau SRM peuvent se bloquer avant la fin, peu après le passage en mode maintenance
    (i) Effectuez la mise à niveau de la version 4.5 vers la version 4.5.0.1
    (II) Effectuez la mise à niveau des versions précédentes vers la version 4.5
  • Sur SRM 4.5 ou 4.5.0.1, le service WSG ne démarre pas sur les machines virtuelles ou les hôtes et consigne les erreurs suivantes :      

SEVERE -- [2021-02-08 14:38:00 AEDT] -- HttpServer$Service::publish(): an unexpected error occurred publishing com.watch4net.apg.webservice.proxy.ManagementServiceProxyHandler
java.lang.IllegalStateException: handler can't be initialized
       (...)
Caused by: javax.servlet.ServletException: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
       (...)
Caused by: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]


Le problème affecte à la fois les hôtes Linux/vApp et Windows.

Cause

Web Service Gateway utilise Jetty, un serveur Web Java et un conteneur de servlets Java. Jetty ne parvient pas à allouer suffisamment de threads aux processus requis. Le nombre ponctuel de threads visibles peut considérablement varier en fonction des différences de matériel (nombre de cœurs de processeur, nombre d’interfaces réseau, différences de noyau, différences de Java, différences de charge, nombre d’utilisateurs actifs, nombre de connexions actives, transactions par seconde, etc.) En général, ce sont les machines virtuelles et les hôtes qui comptent plus de 16 processeurs virtuels qui rencontrent ce problème.

Résolution

Si le nombre de cœurs de processeur d’un des serveurs SRM est supérieur à 16, les journaux WSG affichent des erreurs concernant les threads insuffisants ne permettant pas le démarrage du service WSG. La dernière mise à niveau Jetty vers la version 9.4.34 ou une version ultérieure nécessite la reconfiguration du nombre maximal de threads par défaut (10) afin d’autoriser la création d’un nombre suffisant de threads.

Si votre machine virtuelle ou hôte SRM compte plus de 16 cœurs de processeur, veuillez vous rendre sur le site de support en ligne de Dell EMC (https://dell.com/support) pour ouvrir une demande de service (SR) en citant le numéro de cet article de la base de connaissances.

Produits

SRM, SRM
Propriétés de l’article
Numéro d’article: 000184212
Type d’article: Solution
Dernière modification: 29 août 2022
Version:  6
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