odtwarzanie po awarii w chmurze: wygaszenie przez Amazon Web Services (AWS) obsługi języka Python 2.7 do 15 lipca 2021 r. może wpłynąć na klientów odtwarzania po awarii w chmurze, co może spowodować potencjalną niedostępność danych

Résumé: 15 lipca 2021 r. AWS wycofało obsługę Python 2.7 w interfejsie AWS CLI, co może powodować problemy z Cloud DR.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

15 lipca 2021 r. AWS wycofało obsługę Python 2.7 w AWS CLI, powodując następujące problemy z Cloud DR:
  • Nowe wdrożenie wszystkich wersji Cloud DR
  • Istniejące wdrożenia:
    • Uruchamianie odzyskiwania we wszystkich wersjach Cloud DR Wstrzymanie w wersjach 19.7 i 19.8 
Czego dotyczy problem?
Produkty:
Ten problem dotyczy wszystkich produktów powiązanych z Cloud DR (urządzenia PowerProtect DP, PPDM, autonomiczna usługa Cloud DR i RecoverPoint dla maszyn wirtualnych).

Klienci:
Problem dotyczy wszystkich klientów Cloud DR korzystających z AWS lub AWS GovCloud jako chmury docelowej.

Funkcjonalność:
Nowe instalacje Cloud DR:
  • Nie można wdrożyć CDRS w AWS lub AWS GovCloud (wpływ na wszystkie wersje Cloud DR).
Istniejące wdrożenia Cloud DR: 
  • Nie uruchamia przepływów odzyskiwania w AWS lub AWS GovCloud (wpływ na wszystkie wersje Cloud DR).
  • Nie można uruchomić przepływu przechowywania w AWS lub AWS GovCloud (dotyczy wersji 19.7 i 19.8 Cloud DR).
Czego nie dotyczy problem:
  • Istniejące wdrożenia Cloud DR mogą nadal skutecznie uruchamiać ochronę w AWS lub AWS GovCloud.
  • Problem nie dotyczy klientów Cloud DR korzystających z chmur Azure i Azure Government.

Obejście problemu:
wdrożenie nowego serwera Cloud DR w AWS lub AWS Govcloud wymaga użycia nowego pakietu instalacyjnego jednej z nowych poprawek.

Cause

Problem wynika z zaprzestania świadczenia obsługi Python 2.7 przez AWS. Zobacz informacje o systemie Amazon EOS:
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.

Résolution

Poniżej przedstawiono dwie opcje rozwiązania problemu dla klientów, których dotyczy problem; Tabela 1 zawiera nowe poprawki do wdrażania i aktualizacji; Tabela 2 przedstawia obejście problemu jako alternatywę dla klientów, którzy nie zdecydują się na aktualizację.

Tabela 1
Produkt (system operacyjny lub środowisko operacyjne)
  • Odtwarzanie po awarii w chmurze (Cloud DR) w wersji 19.8 lub starszej z AWS lub AWS GovCloud
  • Ten problem może dotyczyć wszystkich produktów powiązanych z Cloud DR z AWS lub AWS GovCloud
    • Urządzenia PowerProtect DP lub urządzenie zintegrowanej ochrony danych (IDPA)
    • PowerProtect Data Manager (PPDM)
    • Autonomiczna usługa Cloud DR (PowerProtect DD lub Data Domain i Avamar)
    • RecoverPoint for VMs
Problem w tym systemie operacyjnym, środowisku operacyjnym lub oprogramowaniu Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 i 19.1.0.6
TYP DZIAŁANIA UAKTUALNIENIE
Kto może wykonać działanie KLIENT
Szczegółowe informacje o rozwiązaniu W przypadku nowego wdrożenia Cloud DR:
Aktualizacja (lub użycie) Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2 lub 19.2.0.5

Dla klientów Cloud DR PowerProtect/IDPA:
Klienci IDPA w wersji 2.6.1: Uaktualnij do Cloud DR 19.6.0.2
Klienci IDPA w wersji 2.6.0: Uaktualnij do Cloud DR 19.5.0.2
Klienci IDPA w wersji 2.5.0: Uaktualnij do Cloud DR 19.2.0.5
Klienci IDPA w wersji 2.4.1 i 2.3.1: Uaktualnij do Cloud DR 19.1.0.6

Uwaga:
Klienci iDPA w wersji 2.4.0 i 2.3.0: Patrz sekcja „OBEJŚCIE PROBLEMU” w Tabeli 2 (tylko ponowne włączenie przepływów odzyskiwania)

Dla klientów Cloud DR PPDM:
Klienci PPDM w wersji 19.8: Uaktualnij do Cloud DR 19.8.0.2
Klienci PPDM w wersji 19.7: Uaktualnij do Cloud DR 19.7.0.2
Klienci PPDM w wersji 19.6: Uaktualnij do Cloud DR 19.6.0.2
Klienci PPDM w wersji 19.5: Uaktualnij do Cloud DR 19.5.0.2
Klienci PPDM w wersji 19.2: Uaktualnij do Cloud DR 19.2.0.5
Klienci PPDM w wersji 19.3 i 19.4: Aktualizacja do Cloud DR 19.5.0.2 (instancja serwera Cloud DR)

Dla klientów Cloud DR RecoverPoint dla maszyn wirtualnych:
Klienci RecoverPoint dla maszyn wirtualnych w wersji 5.3.2: Uaktualnij do Cloud DR 19.7.0.2
Klienci RecoverPoint dla maszyny wirtualnej w wersji 5.3.1: Uaktualnij do Cloud DR 19.6.0.2
Klienci RecoverPoint dla maszyny wirtualnej w wersji 5.2.x: Uaktualnij do Cloud DR 19.5.0.2

Dla klientów autonomicznej usługi Cloud DR:
Dostępne poprawki aktualizacji dla autonomicznej usługi Cloud DR: 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 i 19.1.0.6
 Klienci autonomicznej usługi Cloud DR 19.3 i 19.4, której dotyczy problem, powinni zaktualizować ją do wersji Cloud DR 19.5.0.2 lub nowszej

Wszystkie pakiety instalacji lub aktualizacji Cloud DR są dostępne pod adresem:
https://www.dell.com/support/home/en-in/product-support/product/data-domain-cloud-dr-for-avamar/drivers


Tabela 2
Obejście problemu dla każdego klienta, który nie zdecyduje się na zastosowanie poprawek Cloud DR wyszczególnionych w Tabeli 1.
 
Produkt (system operacyjny lub środowisko operacyjne)
  • Odtwarzanie po awarii w chmurze (Cloud DR) w wersji 19.8 lub starszej z AWS lub AWS GovCloud
  • Ten problem może dotyczyć wszystkich produktów powiązanych z Cloud DR z AWS lub AWS GovCloud
    • Urządzenia PowerProtect DP
    • PowerProtect Data Manager (PPDM)
    • Autonomiczna usługa Cloud DR (PowerProtect DD lub Data Domain i Avamar)
    • RecoverPoint for VMs
TYP DZIAŁANIA OBEJŚCIE
Kto może wykonać działanie KLIENT
Szczegółowe informacje o rozwiązaniu OBEJŚCIE:

Unikaj usuwania Cloud DR Server (CDRS) lub jakichkolwiek komponentów Cloud DR działających w chmurze.

Nowe rozwiązanie tymczasowe wdrożenia serwera Cloud DR:
Obejście problemu dla urządzeń PowerProtect DP / IDPA, PowerProtect Data Manager i RecoverPoint dla maszyn wirtualnych z istniejącymi wersjami, które nie zawierają stałych poprawek Cloud DR w celu włączenia wdrożenia serwera Cloud DR w AWS i AWS GovCloud

Szczegóły obejścia problemu:
Korzystanie z zewnętrznego dodatku Cloud DR (CDRA) w celu pomyślnego wdrożenia CDRS w AWS lub AWS GovCloud, a następnie podłączenie urządzenia PowerProtect DP, PPDM lub RecoverPoint dla maszyny wirtualnej do tej instancji CDRS.

Czynności do obejścia tego problemu:
  1. Wdrożenie maszyny wirtualnej CDRA przy użyciu nowego pakietu instalacji poprawki wymaganej wersji Cloud DR.
  2. W interfejsie użytkownika CDRA należy wdrożyć CDRS w wymaganym regionie AWS lub AWS GovCloud.
  3. Podłącz urządzenie PowerProtect DP, PPDM lub RecoverPoint dla maszyny wirtualnej z CDRS.
  4. Usuń tymczasową autonomiczną maszynę wirtualną CDRA:
    1. Z opcji menu CDRS System wybierz Registered Components.
    2. Wybierz tymcz. CDRA i kliknij przycisk Unregister.
    3. Wyłącz tymcz. maszynę wirtualną CDRA.
    4. Usuń tymcz. maszynę wirtualną CDRA.

Obejście problemu dla klientów, którzy nie mogą uaktualnić istniejącego CDRS przy użyciu wydanych poprawek w celu ponownego włączenia przepływów pracy odzyskiwania Cloud DR:

Wyczyść wszystkie istniejące komunikaty z odpowiednich kolejek SQS:
  1. Usuń komunikaty konsoli:
    1. Zaloguj się do konsoli AWS.
    2. Wybierz odpowiedni region.
    3. Przejdź do opcji Services > SQS (Simple Queue Service).
    4. Wybierz kolejki RestoreService (począwszy od CDRS-RestoreService), gdzie dostępne wiadomości są większe niż zero (jedna za drugą).
    5. Kliknij akcję i usuń je, aby usunąć wszystkie komunikaty z kolejki.
    6. W polu potwierdzenia wpisz „purge” i kliknij przycisk Purge (Usuń).
  2. Zakończ wszystkie instancje RestoreService:
    1. Zaloguj się do konsoli AWS.
    2. Wybierz odpowiedni region.
    3. Przejdź do Services > EC2 (Amazon EC2) > Auto Scaling groups.
    4. Filtruj grupy automatycznego skalowania (zaczynając od CDRS-RestoreService).
    5. Wybierz grupę automatycznego skalowania, która ma żądaną pojemność powyżej zera.
    6. Kliknij przycisk Edytuj, ustaw żądaną pojemność na zero, a następnie kliknij przycisk Aktualizuj. Spowoduje to zakończenie wszystkich instancji RestoreService.
  3. Zaktualizuj stos RestoreService CF, aby użyć określonej wersji CLI v1:
    1. Zaloguj się do konsoli AWS.
    2. Wybierz odpowiedni region.
    3. Przejdź do sekcji Services > CloudFormation > Stacks.
    4. Usuń zaznaczenie przycisku przełączania View Nested.
    5. Odfiltruj stos RestoreService, którego dotyczy problem (począwszy od CDRS-RestoreService).
    6. Kliknij stos CDRS-RestoreService i przejdź do sekcji „Parameters”.
    7. Skopiuj ciąg zaszyfrowany przez InstanceUserData do narzędzia do odszyfrowywania online (na przykład https://www.base64decode.org/) i dekoduj ten ciąg.
    8. Zmień następujące dwa wiersze w odszyfrowanym skrypcie:
W
    wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip
    rozpakuj awscli-bundle.zip
 DO
    wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip
    unzip awscli-bundle-1.18.200.zip
  1. Zaszyfruj (przy użyciu https://www.base64encode.org/) zaktualizowany, kompletny, odszyfrowany skrypt z powrotem do base64 i skopiuj zaszyfrowany ciąg.
  1. Przejdź do konsoli AWS, kliknij przycisk „Update” w stosie, a następnie wybierz opcję „Use Current Template” i kliknij przycisk Next.
  2. W parametrach zamień wartość pola InstanceUserData na nowy zaszyfrowany ciąg (skopiowany w kroku i).
  3. Kliknij przycisk Next, następnie znów kliknij przycisk Next, zaznacz pola wyboru potwierdzenia, a następnie kliknij przycisk „Update Stack”.
  4. Zapisz zmianę i poczekaj, aż stos zakończy wewnętrzny proces aktualizacji. W ramach tego kroku powinny się zaktualizować wszystkie zagnieżdżone stosy.
  1. Sprawdź, czy przepływy DR i tworzenie kopii Rapid Recovery mogą być teraz kontynuowane i czy kończą się pomyślnie.
  2. Zachowywanie powinno zakończyć się pomyślnie.

Produits concernés

Cloud Disaster Recovery
Propriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version:  9
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.