odtwarzanie po awarii w chmurze: wygaszenie przez Amazon Web Services (AWS) obsługi języka Python 2.7 do 15 lipca 2021 r. może wpłynąć na klientów odtwarzania po awarii w chmurze, co może spowodować potencjalną niedostępność danych
Résumé: 15 lipca 2021 r. AWS wycofało obsługę Python 2.7 w interfejsie AWS CLI, co może powodować problemy z Cloud DR.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
15 lipca 2021 r. AWS wycofało obsługę Python 2.7 w AWS CLI, powodując następujące problemy z Cloud DR:
Produkty:
Ten problem dotyczy wszystkich produktów powiązanych z Cloud DR (urządzenia PowerProtect DP, PPDM, autonomiczna usługa Cloud DR i RecoverPoint dla maszyn wirtualnych).
Klienci:
Problem dotyczy wszystkich klientów Cloud DR korzystających z AWS lub AWS GovCloud jako chmury docelowej.
Funkcjonalność:
Nowe instalacje Cloud DR:
Obejście problemu:
wdrożenie nowego serwera Cloud DR w AWS lub AWS Govcloud wymaga użycia nowego pakietu instalacyjnego jednej z nowych poprawek.
- Nowe wdrożenie wszystkich wersji Cloud DR
- Istniejące wdrożenia:
- Uruchamianie odzyskiwania we wszystkich wersjach Cloud DR Wstrzymanie w wersjach 19.7 i 19.8
Produkty:
Ten problem dotyczy wszystkich produktów powiązanych z Cloud DR (urządzenia PowerProtect DP, PPDM, autonomiczna usługa Cloud DR i RecoverPoint dla maszyn wirtualnych).
Klienci:
Problem dotyczy wszystkich klientów Cloud DR korzystających z AWS lub AWS GovCloud jako chmury docelowej.
Funkcjonalność:
Nowe instalacje Cloud DR:
- Nie można wdrożyć CDRS w AWS lub AWS GovCloud (wpływ na wszystkie wersje Cloud DR).
- Nie uruchamia przepływów odzyskiwania w AWS lub AWS GovCloud (wpływ na wszystkie wersje Cloud DR).
- Nie można uruchomić przepływu przechowywania w AWS lub AWS GovCloud (dotyczy wersji 19.7 i 19.8 Cloud DR).
- Istniejące wdrożenia Cloud DR mogą nadal skutecznie uruchamiać ochronę w AWS lub AWS GovCloud.
- Problem nie dotyczy klientów Cloud DR korzystających z chmur Azure i Azure Government.
Obejście problemu:
wdrożenie nowego serwera Cloud DR w AWS lub AWS Govcloud wymaga użycia nowego pakietu instalacyjnego jednej z nowych poprawek.
Cause
Problem wynika z zaprzestania świadczenia obsługi Python 2.7 przez AWS. Zobacz informacje o systemie Amazon EOS:
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.
Résolution
Poniżej przedstawiono dwie opcje rozwiązania problemu dla klientów, których dotyczy problem; Tabela 1 zawiera nowe poprawki do wdrażania i aktualizacji; Tabela 2 przedstawia obejście problemu jako alternatywę dla klientów, którzy nie zdecydują się na aktualizację.
Tabela 1
Tabela 2
Obejście problemu dla każdego klienta, który nie zdecyduje się na zastosowanie poprawek Cloud DR wyszczególnionych w Tabeli 1.
Tabela 1
| Produkt (system operacyjny lub środowisko operacyjne) |
|
| Problem w tym systemie operacyjnym, środowisku operacyjnym lub oprogramowaniu | Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 i 19.1.0.6 |
| TYP DZIAŁANIA | UAKTUALNIENIE |
| Kto może wykonać działanie | KLIENT |
| Szczegółowe informacje o rozwiązaniu | W przypadku nowego wdrożenia Cloud DR: Aktualizacja (lub użycie) Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2 lub 19.2.0.5 Dla klientów Cloud DR PowerProtect/IDPA: Klienci IDPA w wersji 2.6.1: Uaktualnij do Cloud DR 19.6.0.2 Klienci IDPA w wersji 2.6.0: Uaktualnij do Cloud DR 19.5.0.2 Klienci IDPA w wersji 2.5.0: Uaktualnij do Cloud DR 19.2.0.5 Klienci IDPA w wersji 2.4.1 i 2.3.1: Uaktualnij do Cloud DR 19.1.0.6 Uwaga: Klienci iDPA w wersji 2.4.0 i 2.3.0: Patrz sekcja „OBEJŚCIE PROBLEMU” w Tabeli 2 (tylko ponowne włączenie przepływów odzyskiwania) Dla klientów Cloud DR PPDM: Klienci PPDM w wersji 19.8: Uaktualnij do Cloud DR 19.8.0.2 Klienci PPDM w wersji 19.7: Uaktualnij do Cloud DR 19.7.0.2 Klienci PPDM w wersji 19.6: Uaktualnij do Cloud DR 19.6.0.2 Klienci PPDM w wersji 19.5: Uaktualnij do Cloud DR 19.5.0.2 Klienci PPDM w wersji 19.2: Uaktualnij do Cloud DR 19.2.0.5 Klienci PPDM w wersji 19.3 i 19.4: Aktualizacja do Cloud DR 19.5.0.2 (instancja serwera Cloud DR) Dla klientów Cloud DR RecoverPoint dla maszyn wirtualnych: Klienci RecoverPoint dla maszyn wirtualnych w wersji 5.3.2: Uaktualnij do Cloud DR 19.7.0.2 Klienci RecoverPoint dla maszyny wirtualnej w wersji 5.3.1: Uaktualnij do Cloud DR 19.6.0.2 Klienci RecoverPoint dla maszyny wirtualnej w wersji 5.2.x: Uaktualnij do Cloud DR 19.5.0.2 Dla klientów autonomicznej usługi Cloud DR: Dostępne poprawki aktualizacji dla autonomicznej usługi Cloud DR: 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 i 19.1.0.6 Klienci autonomicznej usługi Cloud DR 19.3 i 19.4, której dotyczy problem, powinni zaktualizować ją do wersji Cloud DR 19.5.0.2 lub nowszej Wszystkie pakiety instalacji lub aktualizacji Cloud DR są dostępne pod adresem: https://www.dell.com/support/home/en-in/product-support/product/data-domain-cloud-dr-for-avamar/drivers |
Tabela 2
Obejście problemu dla każdego klienta, który nie zdecyduje się na zastosowanie poprawek Cloud DR wyszczególnionych w Tabeli 1.
| Produkt (system operacyjny lub środowisko operacyjne) |
|
| TYP DZIAŁANIA | OBEJŚCIE |
| Kto może wykonać działanie | KLIENT |
| Szczegółowe informacje o rozwiązaniu | OBEJŚCIE: Unikaj usuwania Cloud DR Server (CDRS) lub jakichkolwiek komponentów Cloud DR działających w chmurze. Nowe rozwiązanie tymczasowe wdrożenia serwera Cloud DR: Obejście problemu dla urządzeń PowerProtect DP / IDPA, PowerProtect Data Manager i RecoverPoint dla maszyn wirtualnych z istniejącymi wersjami, które nie zawierają stałych poprawek Cloud DR w celu włączenia wdrożenia serwera Cloud DR w AWS i AWS GovCloud Szczegóły obejścia problemu: Korzystanie z zewnętrznego dodatku Cloud DR (CDRA) w celu pomyślnego wdrożenia CDRS w AWS lub AWS GovCloud, a następnie podłączenie urządzenia PowerProtect DP, PPDM lub RecoverPoint dla maszyny wirtualnej do tej instancji CDRS. Czynności do obejścia tego problemu:
Obejście problemu dla klientów, którzy nie mogą uaktualnić istniejącego CDRS przy użyciu wydanych poprawek w celu ponownego włączenia przepływów pracy odzyskiwania Cloud DR: Wyczyść wszystkie istniejące komunikaty z odpowiednich kolejek SQS:
W
wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip rozpakuj awscli-bundle.zip DO wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip unzip awscli-bundle-1.18.200.zip
|
Produits concernés
Cloud Disaster RecoveryPropriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version: 9
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.