雲端災難回復:Amazon Web Services (AWS) 於 2021 年 7 月 15 日停止對 Python 2.7 的支援,這可能會影響雲端災難回復客戶,導致潛在的資料不可用性。
Résumé: 自 2021 年 7 月 15 日起,AWS 已在 AWS CLI 中停用 Python 2.7 支援,這可能會導致雲端 DR 問題。
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Symptômes
自 2021 年 7 月 15 日起,AWS 已在 AWS CLI 中停用 Python 2.7 支援,導致雲端 DR 發生下列問題:
產品:
所有雲端 DR 相關產品都會受到此問題影響 (PowerProtect DP 裝置、PPDM、獨立式雲端 DR,以及 RecoverPoint for VM)。
客戶:
所有使用 AWS 或 AWS GovCloud 作為目標雲端的雲端 DR 客戶都會受到影響。
功能:
全新雲端 DR 安裝:
因應措施:
在 AWS 或 AWS GovCloud 中部署新雲端 DR 伺服器時,需要使用其中一個新發佈修補程式的新安裝套件。
- 新部署所有版本的雲端 DR
- 現有部署:
- 在版本 19.7 和 19.8 上執行所有雲端 DR 版本保留的復原作業
產品:
所有雲端 DR 相關產品都會受到此問題影響 (PowerProtect DP 裝置、PPDM、獨立式雲端 DR,以及 RecoverPoint for VM)。
客戶:
所有使用 AWS 或 AWS GovCloud 作為目標雲端的雲端 DR 客戶都會受到影響。
功能:
全新雲端 DR 安裝:
- 無法在 AWS 或 AWS GovCloud 中部署 CDRS (影響所有雲端 DR 版本)。
- 無法在 AWS 或 AWS GovCloud 中執行復原流程 (影響所有雲端 DR 版本)。
- 無法在 AWS 或 AWS GovCloud 中執行保留流程 (影響版本 19.7 和 19.8 的雲端 DR)。
- 現有的雲端 DR 部署仍可成功執行對 AWS 或 AWS GovCloud 的保護。
- 使用 Azure 和 Azure Government 雲端的雲端 DR 客戶不會受到影響。
因應措施:
在 AWS 或 AWS GovCloud 中部署新雲端 DR 伺服器時,需要使用其中一個新發佈修補程式的新安裝套件。
Cause
此問題是由 AWS 中斷 Python 2.7 支援所造成。請參閱 Amazon EOS 資訊:
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/。
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/。
Résolution
以下為受影響的客戶提供兩種解決方案選項:表 #1 提供新的部署和升級修補程式,表 #2 為不選擇升級的客戶提供因應措施。
表 1
表 2
因應措施,適用於任何未選擇套用表 #1 中詳述的雲端 DR 修補程式的客戶。
表 1
| 產品 (作業系統或作業環境) |
|
| 問題已在此 OS、OE 或軟體中獲得解決 | 雲端 DR 19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2、19.2.0.5 及 19.1.0.6 |
| 動作類型 | 升級 |
| 誰可以完成此動作 | 客戶 |
| 解決方案詳細資料 | 針對雲端 DR 新部署: 升級 (或使用) 雲端 DR 19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2 或 19.2.0.5 針對雲端 DR PowerProtect 或 IDPA 客戶: IDPA 版本 2.6.1 客戶:升級至雲端 DR 19.6.0.2 IDPA 版本 2.6.0 客戶:升級至雲端 DR 19.5.0.2 IDPA 版本 2.5.0 客戶:升級至雲端 DR 19.2.0.5 IDPA 版本 2.4.1 與 2.3.1 客戶:升級至雲端 DR 19.1.0.6 注意: IDPA 版本 2.4.0 和 2.3.0 客戶:請參閱表 #2 的「因應措施」一節 (僅重新啟用復原流程) 針對雲端 DR PPDM 客戶: PPDM 版本 19.8 客戶:升級至雲端 DR 19.8.0.2 PPDM 版本 19.7 客戶:升級至雲端 DR 19.7.0.2 PPDM 版本 19.6 客戶:升級至雲端 DR 19.6.0.2 PPDM 版本 19.5 客戶:升級至雲端 DR 19.5.0.2 PPDM 版本 19.2 客戶:升級至雲端 DR 19.2.0.5 PPDM 19.3 和 19.4 客戶:升級至雲端 DR 19.5.0.2 (雲端 DR 伺服器例項) 針對雲端 DR RecoverPoint for VM 客戶: RecoverPoint for VM 版本 5.3.2 客戶:升級至雲端 DR 19.7.0.2 RecoverPoint for VM 版本 5.3.1 客戶:升級至雲端 DR 19.6.0.2 RecoverPoint for VM 版本 5.2.x 客戶:升級至雲端 DR 19.5.0.2 針對獨立式雲端 DR 客戶: 適用於獨立式雲端 DR 的升級修補程式:19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2、19.2.0.5 和 19.1.0.6 獨立式雲端 DR 19.3 和 19.4 的受影響客戶應升級至雲端 DR 19.5.0.2 或更新版本 所有雲端 DR 的安裝或升級套件皆位於: https://www.dell.com/support/home/en-in/product-support/product/data-domain-cloud-dr-for-avamar/drivers |
表 2
因應措施,適用於任何未選擇套用表 #1 中詳述的雲端 DR 修補程式的客戶。
| 產品 (作業系統或作業環境) |
|
| 動作類型 | 因應措施 |
| 誰可以完成此動作 | 客戶 |
| 解決方案詳細資料 | 因應措施: 避免移除雲端 DR 伺服器 (CDRS) 或在雲端中執行的任何雲端 DR 元件。 全新雲端 DR 伺服器部署因應措施詳細資料: 針對運行不具有經過修正雲端 DR 修補程式之現有版本 PowerProtect DP / IDPA 裝置、PowerProtect Data Manager 和 RecoverPoint for VMs 客戶的因應錯失,以將雲端 DR 伺服器部署至 AWS 和 AWS GovCloud 因應錯失詳細資料: 使用外部雲端 DR 附加元件 (CDRA),以成功將 CDRS 部署至 AWS 或 AWS GovCloud,並在之後將 PowerProtect DP 裝置、PPDM 或 RecoverPoint for VM 連線到該 CDRS 例項。 此因應措施的步驟:
針對無法使用發佈之修補程式升級現有 CDRS 的客戶,重新啟用雲端 DR 復原工作流程的因應措施: 清除相關 SQS 佇列中的所有現有訊息:
從
wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip unzip awscli-bundle.zip 改為 wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip unzip awscli-bundle-1.18.200.zip
|
Produits concernés
Cloud Disaster RecoveryPropriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version: 9
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