Cloud Disaster Recovery: 从 2021 年 7 月 15 日起,Amazon Web Services (AWS) 弃用 Python 2.7 支持可能会影响 Cloud Disaster Recovery 客户,这可能会导致潜在的数据不可用

Résumé: 自 2021 年 7 月 15 日起,AWS 已在 AWS CLI 中终止对 Python 2.7 的支持,这可能导致 Cloud DR 出现问题。

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

自 2021 年 7 月 15 日起,AWS 已在 AWS CLI 中终止对 Python 2.7 的支持,从而导致 Cloud DR 出现以下问题:
  • 所有 Cloud DR 版本的新部署
  • 现有部署:
    • 在所有 Cloud DR 版本上运行恢复,保留在版本 19.7 和 19.8 上 
哪些会受到影响?
产品:
所有 Cloud DR 相关产品都受到此问题影响(PowerProtect DP 备份一体机、PPDM、独立 Cloud DR 和 RecoverPoint for VM)。

客户:
所有将 AWS 或 AWS GovCloud 用作其目标云的 Cloud DR 客户都会受到影响。

功能:
新的 Cloud DR 安装:
  • 无法在 AWS 或 AWS GovCloud 中部署 CDRS(影响所有 Cloud DR 版本)。
现有 Cloud DR 部署: 
  • 无法在 AWS 或 AWS GovCloud 中运行恢复流(影响所有 Cloud DR 版本)。
  • 无法在 AWS 或 AWS GovCloud 中运行保留流(影响 19.7 和 19.8 Cloud DR 版本)。
不受影响的内容:
  • 现有的 Cloud DR 部署仍可成功运行对 AWS 或 AWS GovCloud 的保护。
  • 使用 Azure 和 Azure Government 云的 Cloud DR 客户不会受到影响。

解决办法:
全新地将 Cloud DR Server 部署到 AWS 或 AWS Govcloud 需要使用已发布的其中一个新修补程序的新安装软件包。

Cause

该问题是由于 AWS 停止对 Python 2.7 的支持引起的。请参阅 Amazon EOS 信息:
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/

Résolution

下面是面向受影响客户的两种解决方案选项;表 1 提供新的部署和升级修补程序,表 2 提供一种解决方法,作为不选择升级的客户的替代方案。

表 1
产品(操作系统或操作环境)
  • 使用 AWS 或 AWS GovCloud 的 Cloud Disaster Recovery (Cloud DR) 19.8 及更低版本
  • 所有使用 AWS 或 AWS GovCloud 的 Cloud DR 关联产品可能受此问题影响
    • PowerProtect DP 备份一体机或融合备份一体机 (IDPA)
    • PowerProtect Data Manager (PPDM)
    • 独立 Cloud DR(PowerProtect DD 或 Data Domain 和 Avamar)
    • RecoverPoint for VMs
此 OS、OE 或软件中解决的问题 Cloud DR 19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2、19.2.0.5 和 19.1.0.6
操作类型 升级
谁可以完成操作 客户
解决方案详细信息 对于 Cloud DR 新部署:
升级(或使用)Cloud DR 19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2 或 19.2.0.5

对于 Cloud DR PowerProtect 或 IDPA 客户:
IDPA 版本 2.6.1 客户:升级到 Cloud DR 19.6.0.2
IDPA 版本 2.6.0 客户:升级到 Cloud DR 19.5.0.2
IDPA 版本 2.5.0 客户:升级到 Cloud DR 19.2.0.5
IDPA 版本 2.4.1 和 2.3.1 客户:升级到 Cloud DR 19.1.0.6

注意:
IDPA 版本 2.4.0 和 2.3.0 客户:请参阅表 2 中的“解决方法”部分(仅限重新启用恢复流)

对于 Cloud DR PPDM 客户:
PPDM 版本 19.8 客户:升级到 Cloud DR 19.8.0.2
PPDM 版本 19.7 客户:升级到 Cloud DR 19.7.0.2
PPDM 版本 19.6 客户:升级到 Cloud DR 19.6.0.2
PPDM 版本 19.5 客户:升级到 Cloud DR 19.5.0.2
PPDM 版本 19.2 客户:升级到 Cloud DR 19.2.0.5
PPDM 19.3 和 19.4 客户:升级到 Cloud DR 19.5.0.2(Cloud DR Server 实例)

对于 CCloud DR RecoverPoint for VM 客户:
RecoverPoint for VM 版本 5.3.2 客户:升级到 Cloud DR 19.7.0.2
RecoverPoint for VM 版本 5.3.1 客户:升级到 Cloud DR 19.6.0.2
RecoverPoint for VM 版本 5.2.x 客户:升级到 Cloud DR 19.5.0.2

对于独立 Cloud DR 客户:
适用于独立 Cloud DR 的可用升级修补程序:19.8.0.2、19.7.0.2、19.6.0.2、19.5.0.2、19.2.0.5 和 19.1.0.6
独立 Cloud DR 19.3 和 19.4 影响的客户应升级到 Cloud DR 19.5.0.2 版本或更高版本

所有 Cloud DR 安装或升级软件包均可从以下网址获得:
https://www.dell.com/support/home/en-in/product-support/product/data-domain-cloud-dr-for-avamar/drivers


表 2
未选择应用表 1 中详细介绍的 Cloud DR 修补程序的任何客户的解决方法。
 
产品(操作系统或操作环境)
  • 使用 AWS 或 AWS GovCloud 的 Cloud Disaster Recovery (Cloud DR) 19.8 及更低版本
  • 所有使用 AWS 或 AWS GovCloud 的 Cloud DR 关联产品可能受此问题影响
    • PowerProtect DP 设备
    • PowerProtect Data Manager (PPDM)
    • 独立 Cloud DR(PowerProtect DD 或 Data Domain 和 Avamar)
    • RecoverPoint for VMs
操作类型 解决方法
谁可以完成操作 客户
解决方案详细信息 解决方法:

避免删除 Cloud DR Server (CDRS) 或在云中运行的任何 Cloud DR 组件。

新的 Cloud DR Server 部署解决方法详细信息:
运行现有版本(不包括已修复的 Cloud DR 修补程序)以便将 Cloud DR Server 部署到 AWS 和 AWS GovCloud 的 PowerProtect DP/IDPA 备份一体机、PowerProtect Data Manager 和 RecoverPoint for VM 客户的解决方法

解决方法详细信息:
使用外部 Cloud DR Add-On (CDRA) 将 CDRS 成功部署到 AWS 或 AWS GovCloud,然后将 PowerProtect DP 备份一体机、PPDM 或 RecoverPoint for VM 连接到该 CDRS 实例。

此解决方法的步骤:
  1. 使用所需 Cloud DR 版本的新修补程序安装包部署 CDRA VM。
  2. 从 CDRA UI 中,在所需的 AWS 或 AWS GovCloud 区域部署 CDRS。
  3. 使用 CDRS 连接 PowerProtect DP 设备、PPDM 或 RecoverPoint for VM。
  4. 删除临时的独立 CDRA VM:
    1. 从“CDRS System”菜单选项中,选择已注册的组件。
    2. 选择临时 CDRA,然后单击“Unregister”。
    3. 关闭临时 CDRA VM。
    4. 删除临时 CDRA VM。

对于无法使用已发布的修补程序升级其现有 CDRS 以重新启用 Cloud DR recovery 工作流的客户的解决方法:

清理来自相关 SQS 队列的所有现有消息:
  1. 清除控制台消息:
    1. 登录到 AWS 控制台。
    2. 选择相应的区域。
    3. 转至 Services > SQS (Simple Queue Service)。
    4. 选择可用消息数大于零(一个接一个)的 RestoreService 队列(以 CDRS-RestoreService 开头)。
    5. 单击 action 并清除它们,以清除队列中的所有消息。
    6. 在确认框中写下 "purge",然后单击 Purge 按钮。
  2. 终止所有 RestoreService 实例:
    1. 登录到 AWS 控制台。
    2. 选择相应的区域。
    3. 转至 Services > EC2 (Amazon EC2) > Auto Scaling groups。
    4. 筛选 Auto Scaling groups(以 CDRS-RestoreService 开头)。
    5. 选择所需容量大于零的自动扩展组。
    6. 单击 Edit 按钮,将所需的容量设置为零,然后单击 Update 按钮。这将终止所有 RestoreService 实例。
  3. 更新 RestoreService CF 堆栈以使用特定的 CLI v1 版本:
    1. 登录到 AWS 控制台。
    2. 选择相应的区域。
    3. 转至“Services”>“CloudFormation”>“Stacks”。
    4. 取消选择切换按钮“View Nested”。
    5. 筛选掉受影响的 RestoreService 堆栈(以 CDRS-RestoreService 开头)。
    6. 单击 CDRS-RestoreService 堆栈并转至“Parameters”部分。
    7. 将 InstanceUserData 加密字符串复制到联机解密工具(例如 https://www.base64decode.org/),并对此字符串进行解码。
    8. 在解密脚本中更改以下两行:

    wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip
    unzip awscli-bundle.zip
 更改为
    wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip
    unzip awscli-bundle-1.18.200.zip
  1. 将更新的完整解码脚本(使用 https://www.base64encode.org/)编码回 base64 并复制加密的字符串。
  1. 转至 AWS 控制台,单击堆栈中的“Update”按钮,选择“Use Current Template”单选选项,然后单击“Next”。
  2. 在 Parameters 中,将 InstanceUserData 字段值替换为新的加密字符串(在步骤 i 中拷贝)。
  3. 单击“Next”,再次单击“Next”,选中确认复选框,然后单击“Update Stack”按钮。
  4. 保存更改并等待堆栈完成其内部更新过程。作为此步骤的一部分,它应该会更新所有嵌套堆栈。
  1. 验证灾难恢复流和快速恢复拷贝创建现在可以成功进行和完成。
  2. 保留应成功。

Produits concernés

Cloud Disaster Recovery
Propriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version:  9
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.