VxRail : Échec du bilan de santé pour les tests avec « vs_network »
Résumé: Le contrôle d’intégrité a détecté un avertissement ou une défaillance dans la sortie d’intégrité du réseau vSAN.
Symptômes
Les résultats de ce bilan de santé vSAN (à partir de vCenter) sont signalés comme l’un des résultats suivants :
Test Result |
Result Code |
Result Interpretation |
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No errors were found from vSAN health output. |
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VxVerify found at least one warning result from the vSAN health output. |
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VxVerify found at least one failure resulting from the vSAN health output. |
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This test has no critical result. |
Chaque test réussi n’est pas répertorié dans le rapport récapitulatif, pour en faciliter la lecture.
Un exemple de résultat du bilan d’intégrité figure ci-dessous :
#========================#======#=========#====================================================================#==============# | Hostname / Category |Status Dell_KB | Warnings or Failures, unless tests Passed ; Product S.N. | #========================#======#=========#====================================================================#==============# | VxRM | Failure 218002 | vs_network: Hosts disconnected from VC vxvlab3 Not responding |
Cause
Le test de vérification « vs_network » recueille le résultat du bilan de santé vSAN à partir de vCenter (VC), pour la catégorie Réseau .
Le groupe « Réseau » des bilans de santé vSAN vérifie les éléments suivants :
- « Un vSAN vmknic est configuré sur tous les hôtes »
- « Hôtes déconnectés du VC »
- « Hôtes présentant des problèmes LACP »
- « Hôtes présentant des problèmes de connectivité »
- « Hôtes avec adresses IP en double »
- « partition de cluster vSAN »
- 'vSAN : Vérification de la MTU (ping avec une grande taille de paquet)'
- 'vMotion : Vérification de la MTU (ping avec une grande taille de paquet)'
D’autres tests peuvent être disponibles dans vSphere, en fonction de la version. Toutefois, ils figurent dans les profils de test VxVerify, s’ils sont peu susceptibles de provoquer des problèmes de mise à niveau.
Les résultats complets du bilan de santé VMware vSAN sont répertoriés dans le fichier vxv.log. Voir l’article VxRail : Exécution de l’outil VxRail Verify pour les emplacements des logs.
Résolution
Si des avertissements ou des défaillances s’affichent pour l’une des vérifications d’utilisation de la capacité vSAN, reportez-vous aux articles suivants de la base de connaissances Dell ou VMware :
- Tous les hôtes ont un vSAN vmknic configuré
- Hôtes déconnectés de VC
- Hôtes présentant des problèmes LACP
- Hôtes présentant des problèmes de connectivité
- Hôtes avec des adresses IP en double
- Partition de cluster vSAN
- vSAN : vérification de la MTU (ping avec une taille de paquet volumineuse) (en anglais)
- Vmotion: vérification de la MTU (ping avec une taille de paquet volumineuse) (en anglais)
Pour plus d’informations sur l’objectif des autres bilans de santé VMware vSAN et les résolutions associées, reportez-vous à l’article suivant :
Dell VxRail : Le bilan de santé du nœud échoue pour les tests se terminant par « vsh_ » ou « vs_ » (un compte de support Dell est nécessaire pour afficher cet article)
Idéalement, vSAN Health doit afficher le statut « vert » avant toute tentative de mise à niveau.
Ouvrez vCenter, puis accédez à Hôte et clusters>Onglet Surveillance de l’objet> du cluster Section>vSAN>Sous-section Intégrité sous-section.
Informations supplémentaires
Vous trouverez plus d’informations sur l’événement de défaillance dans le vxv.log.
Par exemple :
2023-09-31 08:30:00-INFO [vs_network] Failure | Hosts with connectivity issues vxvlab4 vxvlab2 2023-09-31 08:30:00-INFO [vs_network] Failure | Hosts disconnected from VC vxvlab3 Not responding
L’équivalent esxcli de ce test est :
esxcli vsan health cluster list
Le document VMware suivant explique comment exécuter ces bilans de santé à partir de vSphere :
Check vSAN Health (https://docs.vmware.com/en/VMware-vSphere/6.7/com.vmware.vsphere.vsan-monitoring.doc/GUID-9504EECF-5946-49FB-86C6-8A4F977F5FC3.html)