PPDM:由于代理和端口问题,SQL AppAware (VM Direct) 配置失败

Résumé: 由于代理授权错误和网络端口限制,PowerProtect Data Manager (PPDM) 中的 SQL AppAware (VM Direct) 配置失败。此问题通常是由 PPDM 服务器、目标虚拟机和 Data Domain 系统之间的通信受阻引起的。

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

受影响的产品:

  • PowerProtect Data Manager (PPDM)

症状:

  • SQL AppAware (VM Direct) 配置在安装过程中失败
  • PPDM 中的错误:
    • Unable to register PowerProtect Agent Service. 
      HTTPSConnectionPool(host='PPDM-server-ip', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration 
      (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 407 Proxy Authorization Required')))
  • vProxy Agent 安装失败,并显示:
    • Command 'C:\Windows\system32\msiexec.exe' terminated with exit code 1601

Cause

  • 端口 7000 无法从 PPDM 服务器访问目标虚拟机
  • 缺少在虚拟机内部署 SQL AppAware 代理的管理员权限
  • 代理配置会阻止出站通信,从而导致 407 需要代理授权 错误

Résolution

要解决此问题:

  1. 确保网络连接:

    • 打开从虚拟机到 PPDM 服务器的端口 8443
    • 打开从虚拟机到 Data Domain 系统的端口 11120492052
    • 打开从 PPDM 到目标虚拟机的端口 7000
  2. 在 SQL AppAware 配置期间使用 FLR Agent 的管理员凭据

  3. 检查代理设置 ,以确保 PPDM 服务器可以在没有代理身份验证错误的情况下进行外部通信

 

提醒:VM Direct 执行数据块级备份,而 SQL AppAware 使用内部代理进行 SQL 事务日志备份。这两个组件都需要与 PPDM 和 DD 系统进行不间断的通信。

Produits concernés

PowerProtect Data Manager, PowerProtect App Direct, PowerProtect Software
Propriétés de l’article
Numéro d’article: 000321643
Type d’article: Solution
Dernière modification: 03 oct. 2025
Version:  1
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.