VNX: Unable to log in directly to CLI with root credential

Summary: Unable to log in directly to CLI with root credential.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to log in to control station directly with root credential, however logging with nasadmin and then doing "su" works to log in to root.

Example:

login as: root
root@abc's password:
Access denied <--------------------------- error while directly log in to root
login as: nasadmin
nasadmin@IP's password:
[nasadmin@CS0 ~]$ <-------------logged in with nasadmin account
[nasadmin@CS0 ~]$ su
Password: <-----------------------------by providing same root password as before, it works
[root@nasadmin]#

 

Cause

The entry of sshd_config has changed.

 

Resolution

Dell Technologies recommends that users log in to the Control Station as nasadmin before issuing the su command to become the root user. For product security, Dell does not recommend logging in to the Control Station directly as root. If the customer protects the nasadmin account and has separate system administration accounts which have access to root, auditing root use is easier. Auditing is not possible when allowing direct access to the root login. However, sometimes, customers may require to configure their systems to allow direct login as root.

  1. Update the following entry on the sshd_config file

    Find the line "PermitRootLogin without-password" in the file sshd_config then replace the entry with "PermitRootLogin yes" using vi editor.

    [root@CS0 nasadmin]# vi /etc/ssh/sshd_config
    PermitRootLogin yes <------------------------updated setting
    # the setting of "PermitRootLogin without-password".
    #ChrootDirectory none
    [root@CS0 nasadmin]#
  2. Restart ssh service

    After the updating the ssh_config file, restart the ssh service using below command.

    [root@CS0 nasadmin]# /sbin/service sshd restart
    Stopping sshd: [ OK ]
    Starting sshd: [ OK ]
    [root@CS0 nasadmin]#

Try to open CLI using root credential.
If the issue still persists, contact Dell Technical Support or your Authorized Service Partner and quote this Knowledgebase ID.

 

Additional Information

It is always recommended to use nasadmin credential to log in to control station then do "su" to get root access.

 

Affected Products

VNX/VNXe

Products

VNX1 Series, VNX2 Series, VNX/VNXe
Article Properties
Article Number: 000082054
Article Type: Solution
Last Modified: 20 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.