PowerProtect Data Manager:Exchange 备份失败,出现初始化错误

Summary: PowerProtect Data Manager:Exchange 备份失败,并显示“初始化错误 — 无法初始化 Exchange shell”

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在应用程序代理日志或导出作业日志中,显示以下错误:

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]145370:msagentsv: 

Initialization error -- Unable to initialize Exchange shell. Required for 

Exchange.
VERBOSE: 
VERBOSE: 2022-12-09T03:30:32.420Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]202816:msagentsv: Unable to

 query Exchange for DAG information when checking for a DAG backup. An 

exception occurred.
VERBOSE: 2022-12-09T03:30:32.425Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]203192:msagentsv: Exception

 occurred in save program: 'Unable to process command line arguments.' .
VERBOSE: 
VERBOSE: 2022-12-09T03:30:32.426Z 

AppBackupAssets_84e38b59c915368f-09Dec2022_10_30_27_661141-36752.log: [TRACE_ID:84e38b59c915368f;EXEC_ID:84077ce121127a95]102333:msagentsv: Exiting 

with failure.


打开新的 Exchange PowerShell,查看它是否正确连接到 Active Directory。

Cause

  1. 配置的用户帐户没有所需的权限(请查看 Exchange 用户指南)。
  2. 安装了其他备份软件(例如,Avamar 客户端或 NetWorker 客户端)。
 

Resolution

  1. 如果未正确向备份帐户授予具有管理员角色的访问权限,请使用 AppAgent Exchange 管理员配置工具配置管理员用户。
  2. 卸载其他备份软件(例如 Avamar 或 NetWorker),然后重新启动主机。

Affected Products

PowerProtect Software
Article Properties
Article Number: 000211377
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  3
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