Dell Automation Platform: On-Premises Installation Fails With Error: Chunk N does Not Exist
Summary: On-Premises Dell Automation Platform installation fails with error: chunk N does not exist. (In this case, N represents a number. The number can be different per attempt.)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
On-Premises Dell Automation Platform installation fails with "error: chunk N does not exist."
For example:
Uploading is not successful. {"http_status_code":400,"messages":[{"message":"chunk 154 does not exists","severity":"ERROR"}]}. Error code: 0x019020002
This issue only applies to upgrading from NativeEdge Orchestrator 3.1 to the Dell Automation Platform 1.0.
Cause
This scenario occurs due to resources allocated to the upgrade-svc service.
Resolution
- Edit the deployment
hzp-upgrade-svc:kubectl edit deployment hzp-upgrade-svc -n hzp
(Replace the namespace with whatever you have NativeEdge Orchestrator installed in) - Find the section:
resources:limits:cpu: "2"memory: 3Gi - Change to:
resources:limits:cpu: "3"memory: 4Gi - Edit the
hpa hzp-upgrade-svc:kubectl edit hpa hzp-upgrade-svc -n hzp
(Replace the namespace with whatever you have NativeEdge Orchestrator installed in) - Change the value:
maxReplicas: 4
TomaxReplicas: 1
(Wait a minute for thehpato reconcile) - Retry the upgrade attempt.
Affected Products
Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdgeArticle Properties
Article Number: 000363912
Article Type: Solution
Last Modified: 11 Oct 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.