NetWorker: VSS 문제로 인한 백업 실패 문제 해결

요약: Microsoft VSS(Volume Shadow Copy Service) 문제로 인해 Windows 클라이언트의 백업이 실패합니다. VSS가 클라이언트 운영 체제에서 스냅샷을 처리하지 못하는 데에는 여러 가지 이유가 있습니다. 예: VSS Writer가 불안정하거나 스냅샷을 생성할 공간이 부족합니다. VSS는 시스템 상태 또는 재해 복구: 세이브 세트에 필요하거나 BBB(Block-Based Backups)를 완료할 때 필요합니다. VSS를 NetWorker 백업과 함께 사용하려면 먼저 호스트 운영 체제에서 안정적이고 올바르게 작동해야 합니다. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

VSS 문제로 인해 Windows 클라이언트의 백업이 실패합니다. VSS가 클라이언트 운영 체제에서 스냅샷을 처리하지 못하는 데에는 여러 가지 이유가 있습니다. 예를 들어: VSS Writer가 불안정하거나 스냅샷을 생성할 공간이 부족합니다.
참고: 이 KB에는 Windows 또는 NetWorker 관리자를 위한 단계가 간략하게 설명되어 있지만 추가 조사를 위해서는 지속적인 VSS 문제를 Microsoft 지원에 제기해야 합니다.

이러한 문제는 일반적으로 NMC에서 확인할 수 있는 백업 로그에 표시됩니다.
VSS OTHER: ERROR: VSS failed to process snapshot: 
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot. 
7259:save: VSS reports adding volume [C:\] <file:///C:/]> to snapshot set failed for both hardware/software provider.VSS OTHER: ERROR: VSS failed to process snapshot: Unexpected VSS provider error.
VSS OTHER: ERROR: VSS failed to process snapshot: Insufficient storage available to create either the shadow copy storage file or other shadow copy data. (VSS error 0x8004231f)
90108:save: Unable to save the SYSTEM STATE save sets: cannot create the snapshot.
VSS 관련 이벤트는 클라이언트의 Windows 이벤트 뷰어에도 표시됩니다.

원인

VSS는 Windows 운영 체제 기능입니다. VSS는 SYSTEM STATE 또는 DISASTER RECOVERY:\ 세이브 세트에 필요하거나 BBB(Block-Based Backup)를 완료할 때 필요합니다. VSS를 NetWorker 백업과 함께 사용하려면 먼저 호스트 운영 체제에서 안정적이고 올바르게 작동해야 합니다.

해결

첫째, 잠재적인 용량 문제를 배제합니다. Microsoft는 VSS 스냅샷을 완료하는 데 사용할 수 있는 총 드라이브 용량의 10-15%를 남겨 둘 것을 권장합니다. 용량이 90%를 초과하면 VSS 스냅샷이 실패할 수 있습니다.

VSS가 클라이언트 운영 체제에서 올바르게 작동하는지 테스트하려면 관리 명령 프롬프트
에서 다음 명령을 실행합니다. 1. VSS writer 상태를 확인합니다. vssadmin list writers
예:

c:\>vssadmin list writers
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Writer name: 'System Writer'
Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Instance Id: {34a07e16-fcdb-4ab0-b603-d58c0f741c9a}
State: [1] Stable
Last error: No error
...
...
참고: 위의 출력은 작성자 중 하나의 예입니다. 그러나 모든 작성자는 안정적이고 오류가 없어야 합니다.


2. writer가 기존 스냅샷을 안정적으로 검사하는 경우 다음이 없어야 합니다. vssadmin list shadows
예:

c:\>vssadmin list shadows
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

No items found that satisfy the query.

3. 스냅샷이 나열되면 삭제합니다. vssadmin delete shadows /all
예:
c:\>vssadmin delete shadows /all
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Do you really want to delete 1 shadow copies (Y/N): [N]? y

Successfully deleted 1 shadow copies.
4. 스냅샷이 없고 디스크 드라이브의 용량 사용률이 90% 미만인 경우 스냅샷 생성을 시도합니다. vssadmin create shadow /for=DRIVE_LETTER:\ 
예: 
c:\>vssadmin create shadow /for=C:\
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2012 Microsoft Corp.

Successfully created shadow copy for 'C:\'
    Shadow Copy ID: {1f6a1448-daad-4e68-a334-31dd40a64dd9}
    Shadow Copy Volume Name: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2
참고: SYSTEM STATE 또는 DISASTER_RECOVERY:\ 세이브 세트에 필요한 각 중요 볼륨에 대해 이 작업을 수행해야 합니다.


5. 스냅샷을 성공적으로 생성한 경우 3단계의 명령을 사용하여 스냅샷을 삭제하고 이 클라이언트의 백업을 실행합니다. VSS 문제로 인해 백업에 실패하는 경우 Dell NetWorker 지원 부서에 문의하십시오. 또한 NetWorker 지원과 Microsoft 지원 간에 협업이 필요한 경우 Microsoft 지원에 문의하는 것이 좋습니다. 

추가 정보

VSS 공간 요구 사항: https://technet.microsoft.com/en-us/library/cc161409.aspx이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.
VSS 정보: https://msdn.microsoft.com/en-us/library/windows/desktop/aa384625(v=vs.85).aspx이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.
고급 VSS 문제 해결 단계는 다음에 설명되어 있습니다. VSS 추적 및 문제 해결 옵션

해결 방법:

VSS 없이 성공적인 백업을 가져오려면 다음 해결 방법을 사용할 수 있습니다.

경고: 이는 솔루션으로 사용하기 위한 것이 아닙니다. 이는 VSS 문제가 해결될 때까지 사용할 임시 해결 방법입니다. VSS가 없으면 DISASTER_RECOVERY:\ 또는 SYSTEM_STATE 백업을 수행할 수 없습니다. 파일 시스템 데이터만 보호됩니다. BBB(Block-Based Backup)를 수행할 때는 이 해결 방법이 불가능합니다.
  1. NMC(NetWorker Management Console)에 로그인합니다.
  2. NMC에서 보기>진단 모드가 활성화되어 있는지 확인합니다.
  3. Protection-Clients> 탭에서 Windows 클라이언트의 속성에 액세스합니다.
  4. 클라이언트 속성의 일반 탭에서 볼륨, 폴더 또는 파일 이름만 포함하도록 세이브 세트 필드를 변경합니다(예: C:\)를 제공해야 합니다.
참고: 세이브 세트 All 을 사용할 수 없습니다. DISASTER_RECOVERY:\는 지정할 수 없습니다.
  1. Apps & Modules 탭에서 vss:*=off 세이브 작업 아래에 있습니다.
  2. 클라이언트의 백업을 수행합니다.
  3. VSS 문제가 해결되면 vss:*=off 설정을 선택하고 클라이언트의 세이브 세트 필드를 All로 설정하거나, DISASTER_RECOVERY:\ 세이브 세트를 포함하여 시스템 상태를 가져옵니다.

해당 제품

NetWorker

제품

NetWorker
문서 속성
문서 번호: 000031318
문서 유형: Solution
마지막 수정 시간: 13 3월 2026
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.