NVP-vProxy: Backups schlagen mit dem Code "-404 "Aging out inactive session" fehl

요약: VM-Backups (virtuelle Maschine), die mit der NetWorker VMware Protection (NVP) vProxy-Appliance durchgeführt werden, schlagen zeitweise fehl, was darauf hinweist, dass die Sitzung veraltet ist. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Die NVP-Integration (NetWorker VMware Protection) wird mit der vProxy-Appliance konfiguriert. Die Backups schlagen zeitweise fehl mit einem resource not found in der NetWorker Management Console. Ein nachfolgendes Backup wird für die virtuelle Maschine abgeschlossen, kann sich jedoch auf andere virtuelle Maschinen auswirken.

Das Backupprotokoll der virtuellen Maschine und die Meldung der NetWorker Management Console werden angezeigt:
{"Text":"Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9","Code":-404}
Das Backupaktionsprotokoll zeigt Folgendes an:
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to obtain backup status from vProxy after 5 attempts, failing the backup: Received an HTTP code: 404, libCURL message: "", vProxy message: "Error received from vProxy ="-404: Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9". ", url: "https://ii170-vproxy01.fastenal.com:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9", body: " ".
MM/DD/YY HH:MM:SS [VM_NAME]: Unable to download vProxy Session log into file '/nsr/logs/policy/VMWare Protection/[WORKFLOW]/461300-[VM_NAME]-YYYY-MM-DD-HH-MM-SS.log': Possible wrong vProxy hostname or port, resource path not found. Received an HTTP code: 404, libCURL message: "", url: "https://[VPROXY_NAME]:9090/api/v1/BackupVmSessions/44ab916f-7519-40f9-9d2e-e90394782ed9/log".
MM/DD/YY HH:MM:SS [VM_NAME]: Backup failed.
MM/DD/YY HH:MM:SS The size of proxied data written has not been set.
MM/DD/YY HH:MM:SS Save-set ID '849786629' (client '[VCENTER_NAME]': save-set 'vm:50308677-bf8b-c786-0140-6a9c4409b90f:[VCENTER_NAME]') is aborted.
Die vProxy-vbackupd-engine.log zeigt Folgendes an:
YYYY/MM/DD HH:MM:SS TRACE:  Ending go routine of main session loop for *resources.BackupVmSessions (vm-29424) [VM_NAME].
YYYY/MM/DD HH:MM:SS NOTICE: 44ab916f-7519-40f9-9d2e-e90394782ed9:vm-29424:[VM_NAME]: Backup session is exiting
YYYY/MM/DD HH:MM:SS TRACE:  Resource Update 44ab916f-7519-40f9-9d2e-e90394782ed9:externalId=[VCENTER_NAME]:vm-29424:state=Success:deletable=true.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS NOTICE: Aging out inactive session BackupVmSessions - 44ab916f-7519-40f9-9d2e-e90394782ed9 ([VCENTER_NAME]:vm-29424) last accessed YYYY-MM-DD HH:MM:SS -0500 CDT.
YYYY/MM/DD HH:MM:SS TRACE:  Deleting logfiles of session '44ab916f-7519-40f9-9d2e-e90394782ed9'...
YYYY/MM/DD HH:MM:SS TRACE:  Deleting log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9"...
YYYY/MM/DD HH:MM:SS INFO:   File '/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log'.
YYYY/MM/DD HH:MM:SS INFO:   Deleted log file "/opt/emc/vproxy/runtime/logs/vbackupd/44ab916f-7519-40f9-9d2e-e90394782ed9.log" while deleting session "44ab916f-7519-40f9-9d2e-e90394782ed9".
YYYY/MM/DD HH:MM:SS TRACE:  Deleting resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS INFO:   Deleted resource: [VCENTER_NAME]:vm-29424 - 44ab916f-7519-40f9-9d2e-e90394782ed9.
YYYY/MM/DD HH:MM:SS INFO:   Saved resource map to "/opt/emc/vproxy/runtime/state/vbackupd/BackupVmSessions.gob".
YYYY/MM/DD HH:MM:SS INFO:   Aged out 1 'BackupVmSessions' sessions, 0 remaining
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Handling Action GetLog for 44ab916f-7519-40f9-9d2e-e90394782ed9 ...
YYYY/MM/DD HH:MM:SS ERROR:  Resource not found: 44ab916f-7519-40f9-9d2e-e90394782ed9
YYYY/MM/DD HH:MM:SS TRACE:  Reply sent successfully for "GetLog".

원인

Der NetWorker-Server überprüft kontinuierlich den Status der Backupsitzung und fordert die Protokolle an, sobald die Backupsitzung abgeschlossen ist. Der vProxy schließt das Backup ab und altert die Sitzung, nachdem der NetWorker-Server einige Minuten lang keine Aktualisierung angefordert hat. Wenn die Sitzung veraltet ist, kann der vProxy dem NetWorker-Server keine Statusaktualisierungen oder Protokolle mehr geben, und es schlägt mit dem Befehl fehl resource not found Fehlers Verzögerungen bei der NetWorker-Serverstatusanfrage sind in der Regel auf die hohe Latenz zwischen dem NetWorker-Speicher-Node und der Data Domain-Kommunikation zurückzuführen.

해결

Die Latenz zwischen NetWorker-Speicher-Node und Data Domain sollte während der Backupausführung auf weniger als 50 ms reduziert werden. Diese Richtlinie ist im Abschnitt "Überlegungen zur TCP-Fenstergröße und Netzwerklatenz" im Dell NetWorker Performance Optimization Planning Guide dokumentiert. Wenn die Latenz nicht reduziert werden kann, wird empfohlen, einen NetWorker-Speicher-Node am Remotestandort für das Management der Data Domain-Geräte zu konfigurieren.

Im folgenden Artikel wird beschrieben, wie Sie ein Netzwerk-Troubleshooting durchführen: NetWorker: Anleitung zum Troubleshooting bei Netzwerkproblemen.

Im obigen Artikel wird beschrieben, wie Sie einen Ping mit Zeitstempel vom NetWorker-Speicher-Node und Data Domain durchführen. Bestätigen Sie, dass die Zeitzonen übereinstimmen, und lassen Sie den Ping-Vorgang im Hintergrund laufen und in eine Datei ausgeben. Wenn das Backupproblem reproduziert wird, überprüfen Sie den Zeitbereich der Ping-Ausgabedatei auf hohe Latenz während des Zeitraums, in dem das Backupproblem beobachtet wurde. 

해당 제품

NetWorker

제품

NetWorker
문서 속성
문서 번호: 000034020
문서 유형: Solution
마지막 수정 시간: 03 10월 2025
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.