Data Domain: Disk Unknown

요약: This article explains why a disk may appear as "Unknown" in a Data Domain system and provides steps to identify and resolve the issue.

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증상

A disk displays the state "Unknown" in the DD-CLI, DDSM, or DDMC.

The issue affects one of the following scenarios:

  • A single disk in the controller (head unit) or attached storage
  • All disks in a newly added enclosure
  • A disk recently replaced after failure

원인

A disk may report as "Unknown" for one of the following reasons:

  • The system has not yet recognized a newly installed disk.
  • A disk is unreliable or failed and reports an unknown state.
  • A newly added enclosure has not been integrated into the RAID configuration.
  • A replacement disk has not been initialized or transitioned to an active state.

해결

Follow the steps below based on the scenario:

  1. Check Your Data Domain Model

    Important: The disk unfail command is not supported on storage pool architecture systems (for example, DD6400). Running this command on these models results in an error.

    • Identify your system model:

      system show modelno
      
    • Use the correct procedure:

      DD6400 (Storage Pool Architecture):

      All Other Data Domain Models (Traditional DD-RAID Architecture):

      • Continue with the steps below (disk rescan, disk unfail).
  2. Verify Disk State

  3. Single Disk Reports "Unknown" (and is NOT a new replacement disk)

    • Check active system alerts (alerts show current) and disk state (disk show state). If the disk is reported as failed, and is in an "Unknown" state, replace it.
    • If the "Unknown" disk is a newly installed (replacement) disk, see Step 5.
  4. All Disks in a New Enclosure Report "Unknown"

    • This is expected behavior for a newly added shelf.
      • Follow the relevant Shelf Hardware Guide to get the "Unknown" disks added to storage capacity.
        • Overview of the required steps to add a shelf:
          • Apply licensing
          • Add storage to the correct tier (active or cloud)
          • Expand the filesystem
  5. Single Disk Reports "Unknown" After Replacement

    • Attempt a rescan of drives. From DD-CLI (ssh), Run command # disk rescan
    • Verify status of drive from DD-CLI # disk show state
      • If the disk has become 'In-use' and the alert has not cleared, manually clear the alert using DD-CLI # alerts clear alert-id <alert-id>
      • If the disk remains 'unknown' - run the # disk unfail <encl.disc> command to transition the disk to a spare state.
  6. Need Additional Assistance
    Contact your contracted support provider and raise a service request if the issue remains unresolved.

추가 정보

Best Practice: Two-Minute Wait During Disk Swap

  • When physically replacing a disk drive, wait at least 2 minutes after removing the failed disk before inserting the new disk.
  • This allows the controller firmware to properly deregister the old drive, greatly reducing the possibility of a hotplug issue where the new drive is not properly recognized (showing as "unknown").

Recommended sequence:

  1. Remove the failed disk from the slot.
  2. Wait two minutes.
  3. Insert the new replacement disk.

해당 제품

Data Domain

제품

Data Domain
문서 속성
문서 번호: 000043258
문서 유형: Solution
마지막 수정 시간: 30 6월 2026
버전:  6
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