Dell Unity: 풀 가득 참 이벤트 중 스토리지 프로세서 패닉

요약: 이 문서에서는 풀이 100% 소비되었을 때 SP(Storage Processor) 패닉이 발생하는 이유를 설명하고 문제 해결 옵션을 제공합니다.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

스토리지 풀이 100% 찼습니다.

풀이 가득 차고 하나 이상의 FS(File System) 또는 LUN(Logical Unit Number)이 오프라인으로 표시되고 복구가 필요한 경우 스토리지 프로세스에 패닉이 발생합니다. 오프라인으로 표시된 하나 이상의 FS 또는 LUN에 대한 스냅샷도 복구해야 합니다.

원인

패닉의 순서 :

  1. 풀이 100% 가득 차고 어레이가 스냅샷을 무효화하기 시작합니다.
  2. 어레이에서 스냅샷 마운트 해제를 시작합니다.
  3. 어레이는 할당을 위해 메타데이터 및 수퍼 블록을 업데이트하려고 시도합니다 getSlice명령을 수행할 수 있는 충분한 공간이 있어야 합니다. 풀이 100% 차 있기 때문에 실패합니다.
  4. 스냅샷을 마운트 해제하는 작업이 시간 초과되고 SP 패닉이 발생합니다.

해결

FS, LUN 및 스냅샷의 풀에 사용 가능한 용량이 있어야 복구 시도를 시작할 수 있습니다. 이 작업은 영향을 받는 풀을 확장하여 수행됩니다.

영향을 받는 풀을 확장할 수 없는 경우 다음 방법 중 하나를 사용하여 풀에 사용 가능한 공간을 만들어야 합니다.

추가 도움이 필요한 경우 Dell 기술 지원 부서에 문의하고 이 Dell 기술 자료 문서를 참조하십시오.

추가 정보

불필요한 스냅 샷을 삭제하는 방법 

1단계: 풀 사용량 확인:

  • Unisphere 크랙:
    • 스토리지 > 풀
    • 영향을 받는 풀을 선택하고 Used (%) 열에 나열되어 있습니다.
    • 풀 이름을 클릭하면 스냅샷에서 사용된 공간을 포함한 자세한 사용량을 볼 수 있습니다.
  • CLI:
    • 서비스 자격 증명을 사용하여 Putty에 로그인합니다.
    • 다음 명령을 실행합니다. uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool show -detail 

 

2단계: 크거나 오래된 스냅샷 식별:

  • Unisphere 크랙:
    • STORAGE > 블록 > LUN 또는 STORAGE > 파일 > 파일 시스템
    • 각 LUN 또는 파일 시스템에 대해 Snapshots 탭을 확인합니다.
  • CLI: 
    • 서비스 자격 증명을 사용하여 Putty에 로그인합니다.
    • 다음 명령을 실행하여 스냅샷 세부 정보를 확인합니다. uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /prot/snap show -detail 
    • 다음 명령을 실행하여 개별 스토리지 리소스에서 사용하는 스냅샷 공간을 확인합니다. uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool/sr -pool <pool name> show -detail
    • Example:
uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool/sr -pool pool_1 show -detail 

 ID = sv_1
 Name = AF LUN 1
 Resource type = LUN
 Pool = pool_1
 Total pool space used = 14448566272 (13.4G)
 Total pool preallocated = 4610351104 (4.2G)
 Total pool snapshot space used = 4593991680 (4.2G)
 Total pool non-base space used = 4593991680 (4.2G)
 Health state = OK (5)
 Health details = "The LUN is operating normally. No action is required."

 

3단계: 스냅샷 삭제:

⚠️ 주의: 삭제하기 전에 백업 또는 복구에 스냅샷이 필요하지 않은지 확인합니다. ⚠️

  • Unisphere 크랙:
    • 삭제할 스냅샷을 하나 이상 선택합니다.
    • Delete를 클릭하고 작업을 확인합니다.
    • 필요에 따라 다른 LUN 또는 FS에 대해 반복합니다.
  • CLI:
    • 다음 명령을 실행합니다. uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /prot/snap –id <Snapshot ID> delete

4단계: 풀 사용량 모니터링:

  • Unisphere 크랙:
    •  삭제 후 STORAGE Pools > 로 돌아갑니다.
    • 페이지 새로 고침 및 모니터링 Used (%) 값.
    • 공간을 회수하는 데 몇 분 정도 걸릴 수 있습니다.
  • CLI:
    • 다음 명령을 실행합니다. uemcli -d 10.0.0.1 -u Local/joe -p MyPassword456! /stor/config/pool show -detail 

추가 팁:

  • 스냅샷 삭제 자동화: 보존 정책을 설정하여 이전 스냅샷을 자동으로 삭제합니다.
  • 스냅샷 일정 검토: 지나치게 빈번한 스냅샷 생성을 피하십시오.
  • 알림 활성화: 풀 사용량 임계값(예: 80%, 90%)에 대한 알림을 구성하여 사전 예방적으로 작동합니다.

관련 문서: 

관련 Dell 기술 자료 문서:

해당 제품

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Hybrid

제품

Dell Unity 300, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
문서 속성
문서 번호: 000052729
문서 유형: Solution
마지막 수정 시간: 17 4월 2026
버전:  6
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.